aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2021-06-15 20:45:59 +0200
committerBart Ribbers <bribbers@disroot.org>2021-06-15 20:45:59 +0200
commit04477874d2d7841fc5177c36d8f264375036bce8 (patch)
treea21948d9632fe0904df1e4bf7dddb5cf031af175
parentf3cc897cc1d961d9328aabaa157fbe5eaaf44317 (diff)
community/libcsys: disable on riscv64 and modernize
-rw-r--r--community/libcsys/APKBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/community/libcsys/APKBUILD b/community/libcsys/APKBUILD
index 65182f5a686..b598247dd9b 100644
--- a/community/libcsys/APKBUILD
+++ b/community/libcsys/APKBUILD
@@ -4,25 +4,28 @@ pkgname=libcsys
pkgver=4.2.0
pkgrel=0
pkgdesc="Library for managing drive and getting system resource information in real time"
-arch="all !s390x !mips64" # polkit
+# s390x, mips64 and riscv64 blocked by polkit
+arch="all !s390x !mips64 !riscv64"
url="https://gitlab.com/cubocore"
license="GPL-3.0-or-later"
depends="qt5-qtbase udisks2"
makedepends="qt5-qtbase-dev cmake ninja"
-source="$pkgname-$pkgver.tar.gz::https://gitlab.com/cubocore/libcsys/-/archive/v$pkgver/libcsys-v$pkgver.tar.gz"
+source="https://gitlab.com/cubocore/libcsys/-/archive/v$pkgver/libcsys-v$pkgver.tar.gz"
subpackages="$pkgname-dev"
builddir="$srcdir/$pkgname-v$pkgver"
-options="!check"
+options="!check" # No tests
build() {
- cmake ../$pkgname-v$pkgver \
- -GNinja \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
- ninja
+ cmake --build build
}
package() {
- DESTDIR="$pkgdir" ninja install
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="ff9b98788f094db7d9574bf507049596a9a46e7532ede806b1e0369d77934e2d74d451f7d5ffd77bf2111c4a4fd8aea47ea86ef44a316bd2f211e955fb1cafaa libcsys-4.2.0.tar.gz"
+sha512sums="
+ff9b98788f094db7d9574bf507049596a9a46e7532ede806b1e0369d77934e2d74d451f7d5ffd77bf2111c4a4fd8aea47ea86ef44a316bd2f211e955fb1cafaa libcsys-v4.2.0.tar.gz
+"