aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Polański <michal@polanski.me>2020-08-02 03:06:41 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-08-02 18:58:31 +0000
commit069decf0b495d36fb77dc1845709e246e90253b6 (patch)
tree71d47a304299236ff8b6f53a4d7210dc210d2845
parenta430ad5566bf9767ace292c3e075b3e4c49f4580 (diff)
community/rssh: use SPDX license identifier
and fix linter warnings
-rw-r--r--community/rssh/APKBUILD18
-rw-r--r--community/rssh/makefile.patch3
2 files changed, 10 insertions, 11 deletions
diff --git a/community/rssh/APKBUILD b/community/rssh/APKBUILD
index e7f78e1dc07..4be25a4140f 100644
--- a/community/rssh/APKBUILD
+++ b/community/rssh/APKBUILD
@@ -2,24 +2,22 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=rssh
pkgver=2.3.4
-pkgrel=0
+pkgrel=1
pkgdesc="Restricted shell for use with OpenSSH, allowing only scp, sftp, and/or rsync"
url="http://www.pizzashack.org/rssh/"
arch="all"
-license="BSD"
+license="BSD-2-Clause"
depends="openssh"
makedepends="rsync"
install="$pkgname.post-install $pkgname.post-deinstall"
subpackages="$pkgname-doc"
-source="https://prdownloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
+source="https://prdownloads.sourceforge.net/rssh/rssh-$pkgver.tar.gz
makefile.patch
fix-error-message-for-invalid-option.patch
handle-rsync-v3-e-option.patch"
options="suid"
-builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -27,17 +25,15 @@ build() {
--libexecdir=/usr/lib/$pkgname \
--sysconfdir=/etc \
--mandir=/usr/share/man \
- --localstatedir=/var \
- || return 1
- make || return 1
+ --localstatedir=/var
+ make
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
sha512sums="c1a77abdf4abe5f936fb1c9c008fc81fabf7b624d69ed31fe2ae5619dfa4a79f1d4a4f2daa5291a36d40353fa2168e74e5ba61294230d702fcdc88ae0d520487 rssh-2.3.4.tar.gz
-24a58353ed2714eafe26326e5a4065bac83bcb20af07ddb64270b9ed607127c896947c45badf2e67b18672ced90557c885ce13fc540cc3bbb0bc6b7e547f0c11 makefile.patch
+7b1120b47a1c5d251f002d4196ffac66bcc4518b34284831932d7ef0aae839777c8188cb2addacb57241b6208c03c5b14f1845a50bb5b72461f80a7f943ef051 makefile.patch
abad4a707f7851c60549d6073c331a4a2b47bdcf97956d5cbad3af9bcb83d6ad33694ac3270df5c7df6ec709026e0253c49024fa20a33a453524547031df77aa fix-error-message-for-invalid-option.patch
942dd8e0495cf13bbb679332cab6c1781560e32ade0905527fe71e5399f930edfe0c442653deb218a182b11e49599c3bd78d0fc715de45cf9aa078e6a586b9c7 handle-rsync-v3-e-option.patch"
diff --git a/community/rssh/makefile.patch b/community/rssh/makefile.patch
index ac13d67dd49..ad75dd30a67 100644
--- a/community/rssh/makefile.patch
+++ b/community/rssh/makefile.patch
@@ -1,3 +1,6 @@
+Upstream: No
+Reason: Respect required environment variables
+
--- a/Makefile.in
+++ b/Makefile.in
@@ -727,10 +727,10 @@ uninstall-man: uninstall-man1 uninstall-