aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Klitzing <aklitzing@gmail.com>2017-10-23 22:25:05 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2017-10-26 09:38:48 +0000
commit0728785ecd984a04aeb41d6fec676bbf438a01e2 (patch)
tree49b4327903dbecbcd6890f71d077c147b2f27949
parent1c5a2d129679082f026871113b0feda8c7e157c5 (diff)
community/bubblewrap: upgrade to 0.2.0 and modernize abuild
-rw-r--r--community/bubblewrap/APKBUILD18
-rw-r--r--community/bubblewrap/musl-fixes.patch17
2 files changed, 26 insertions, 9 deletions
diff --git a/community/bubblewrap/APKBUILD b/community/bubblewrap/APKBUILD
index bbb99583b61..d33b1303e09 100644
--- a/community/bubblewrap/APKBUILD
+++ b/community/bubblewrap/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Timo Teräs <timo.teras@iki.fi>
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=bubblewrap
-pkgver=0.1.8
+pkgver=0.2.0
pkgrel=0
pkgdesc="Unprivileged sandboxing tool"
url="https://github.com/projectatomic/bubblewrap"
@@ -11,13 +11,13 @@ options="!check suid"
makedepends="autoconf automake libcap-dev docbook-xsl"
subpackages="$pkgname-doc $pkgname-bash-completion:bashcomp:noarch"
source="bubblewrap-$pkgver.tar.gz::https://github.com/projectatomic/bubblewrap/archive/v$pkgver.tar.gz
- realpath-workaround.patch"
+ realpath-workaround.patch musl-fixes.patch"
builddir="$srcdir/$pkgname-$pkgver"
prepare() {
- default_prepare
cd "$builddir"
NOCONFIGURE=1 ./autogen.sh
+ default_prepare
}
build() {
@@ -29,9 +29,8 @@ build() {
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--localstatedir=/var \
- --with-priv-mode=setuid \
- || return 1
- make || return 1
+ --with-priv-mode=setuid
+ make
}
package() {
@@ -45,8 +44,9 @@ bashcomp() {
install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
mkdir -p "$subpkgdir"/usr/share/
- mv "$pkgdir"/usr/share/bash-completion/ "$subpkgdir"/usr/share/ || return 1
+ mv "$pkgdir"/usr/share/bash-completion/ "$subpkgdir"/usr/share/
}
-sha512sums="b8dd214165fd486f0bc16d6aabc0159154f23744f09f3b6b3b3f2b7a028d732651fdec8ca7ab38d9be302d4e6b3c82adcb0c4865893b1df893ca6ac4d9ca9070 bubblewrap-0.1.8.tar.gz
-400a0446670ebf80f16739f1a7a2878aadc3099424f957ba09ec3df780506c23a11368f0578c9e352d7ca6473fa713df826fad7a20c50338aa5f9fa9ac6b84a4 realpath-workaround.patch"
+sha512sums="746f10cd9f9852ca4679d589357402ec10c352e02f77384844a4657fd9b2952189a3299319fbefedd35358d39fd16ded63cc3db95041ed2091548183786b8b63 bubblewrap-0.2.0.tar.gz
+400a0446670ebf80f16739f1a7a2878aadc3099424f957ba09ec3df780506c23a11368f0578c9e352d7ca6473fa713df826fad7a20c50338aa5f9fa9ac6b84a4 realpath-workaround.patch
+f59cda3b09dd99db9ca6d97099a15bb2523e054063d677502317ae3165ba2e32105a0ae8f877afc3827bd28d093c9d9d413270f4c87d9fe5f26f3eee670d916e musl-fixes.patch"
diff --git a/community/bubblewrap/musl-fixes.patch b/community/bubblewrap/musl-fixes.patch
new file mode 100644
index 00000000000..ecf6263310b
--- /dev/null
+++ b/community/bubblewrap/musl-fixes.patch
@@ -0,0 +1,17 @@
+--- a/config.h.in
++++ b/config.h.in
+@@ -102,3 +102,14 @@
+
+ /* Define to 1 if you need to in order for `stat' and other things to work. */
+ #undef _POSIX_SOURCE
++
++/* taken from glibc unistd.h and fixes musl */
++#ifndef TEMP_FAILURE_RETRY
++#define TEMP_FAILURE_RETRY(expression) \
++ (__extension__ \
++ ({ long int __result; \
++ do __result = (long int) (expression); \
++ while (__result == -1L && errno == EINTR); \
++ __result; }))
++#endif
++