aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScrumpyJack <scrumpyjack@st.ilet.to>2016-03-16 14:14:57 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-03-18 06:33:01 +0000
commit07624a38ce263a899c41d9cdffb3656dc7bcef7d (patch)
tree2130e79fa1281a0386a40b4f5e32f2f3732752ef
parentf6b128007fdfafa3cd3e96dfcad767b55272c4c6 (diff)
testing/wmctrl: new aport
wmctrl is a UNIX/Linux command line tool to interact with an EWMH/NetWM compatible X Window Manager https://sites.google.com/site/tstyblo/wmctrl
-rw-r--r--testing/wmctrl/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/testing/wmctrl/APKBUILD b/testing/wmctrl/APKBUILD
new file mode 100644
index 00000000000..74e017a9ad7
--- /dev/null
+++ b/testing/wmctrl/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: ScrumpyJack <scrumpyjack@st.ilet.to>
+# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
+pkgname=wmctrl
+pkgver=1.07
+pkgrel=0
+pkgdesc="wmctrl is a UNIX/Linux command line tool to interact with an EWMH/NetWM compatible X Window Manager"
+url="https://sites.google.com/site/tstyblo/wmctrl"
+arch="all"
+license="GPL"
+depends=""
+depends_dev=""
+makedepends="libxmu-dev libx11-dev glib-dev"
+install=""
+subpackages="$pkgname-doc"
+source="https://sites.google.com/site/tstyblo/wmctrl/wmctrl-1.07.tar.gz"
+
+_builddir=${srcdir}/${pkgname}-${pkgver}
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man || return 1
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="1fe3c7a2caa6071e071ba34f587e1555 wmctrl-1.07.tar.gz"
+sha256sums="d78a1efdb62f18674298ad039c5cbdb1edb6e8e149bb3a8e3a01a4750aa3cca9 wmctrl-1.07.tar.gz"
+sha512sums="4c77ad1e204e8d444f682ad1d05c0993bcab9097ac6d4b6a944556ab85acbe713f549dbaf443cd4d1226a162ce7d46fbd209c92652e87fc8e609feee74907daa wmctrl-1.07.tar.gz"