aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2021-01-14 10:32:11 +0100
committerLeo <thinkabit.ukim@gmail.com>2021-01-14 18:52:46 +0000
commit07651ee52ce5e66ae5ac3c24a0ae06a90e38e00f (patch)
treecc12e3abbfb350b765fc13cbb1cf59d7113e26c1
parenta9a66530e3007cd03f88179f49b865f8bcd94cae (diff)
main/uboot-tools: modernize
- Clarify license - Cleanup - Switch source to https
-rw-r--r--main/uboot-tools/APKBUILD38
-rw-r--r--main/uboot-tools/defang-efi-bootcmd.patch2
2 files changed, 21 insertions, 19 deletions
diff --git a/main/uboot-tools/APKBUILD b/main/uboot-tools/APKBUILD
index 82e7be42019..712445bce82 100644
--- a/main/uboot-tools/APKBUILD
+++ b/main/uboot-tools/APKBUILD
@@ -2,46 +2,48 @@
# Maintainer: Fathi Boudra <fathi.boudra@linaro.org>
pkgname=uboot-tools
pkgver=2021.01
-pkgrel=0
+pkgrel=1
pkgdesc="U-Boot bootloader utility tools"
url="https://www.denx.de/wiki/U-Boot/WebHome"
arch="all !s390x !ppc64le"
-license="GPL"
-makedepends="$depends_dev bison flex openssl-dev linux-headers"
-subpackages="$pkgname-examples"
+license="GPL-2.0-or-later"
+makedepends="bison flex openssl-dev linux-headers"
+subpackages="$pkgname-examples::noarch"
options="!check" # No test suite
-source="http://ftp.denx.de/pub/u-boot/u-boot-$pkgver.tar.bz2
+source="https://ftp.denx.de/pub/u-boot/u-boot-$pkgver.tar.bz2
fix-ulong-typedef.patch
defang-efi-bootcmd.patch
"
builddir="$srcdir/u-boot-$pkgver"
build() {
- cd "$builddir"
make defconfig
make tools-all
}
-examples() {
- mkdir -p "${subpkgdir}/usr/share/doc/${pkgname}"
- mv "${pkgdir}/usr/share/doc/${pkgname}/examples/" \
- "${subpkgdir}/usr/share/doc/${pkgname}"
-}
-
package() {
- cd "$builddir"
+ local tool
for tool in bmp_logo dumpimage env/fw_printenv \
fit_check_sign fit_info gdb/gdbcont gdb/gdbsend gen_eth_addr img2srec \
- mkenvimage mkimage ncb proftool ubsha1 xway-swap-bytes env/fw_printenv; do
- install -D tools/$tool \
- $pkgdir/usr/bin/$(basename $tool)
+ mkenvimage mkimage ncb proftool ubsha1 xway-swap-bytes;
+ do
+ install -D tools/"$tool" "$pkgdir"/usr/bin/"$(basename $tool)"
done
+
install -Dm644 tools/env/fw_env.config \
- "${pkgdir}/usr/share/doc/${pkgname}/examples/fw_env.config"
+ "$pkgdir"/usr/share/doc/"$pkgname"/examples/fw_env.config
+
cd "$pkgdir"/usr/bin
ln -sf fw_printenv fw_setenv
}
+examples() {
+ pkgdesc="$pkgdesc (Examples)"
+ depends=""
+
+ amove usr/share/doc/"$pkgname"
+}
+
sha512sums="40dd4d9ef87a1829158658c433d46a047a39c0d8c314ad8d133f7240343ee3a75b060f009dd2efe598cfb8a766773f6cd773ea7f7745ee88e52a771c77eb1c6e u-boot-2021.01.tar.bz2
813dd152afa8863d3c7456449c9b0b358232edae7c8575ebe4af71bfe74019d4c27f30dc6fcf307018e36f5afdaf7de32253c0a773955d5be74c625ddd5668c7 fix-ulong-typedef.patch
-ae4fa0a1e11fe862fc30d78d52616ede65b87893e656d7bca0c3e269d744ed477a23185f1d61e91e9beb765c5bafcbcba65699ca9835a516637098ef332644df defang-efi-bootcmd.patch"
+28afb6d084e9c4c380a4783e7e1e826dcbd0c7dbcd4e7787303c82013a2b280d9d9446cb9a19c0b6e90f5884b4d9f2524d99bfe1f353c89f6facd1af5e2c206f defang-efi-bootcmd.patch"
diff --git a/main/uboot-tools/defang-efi-bootcmd.patch b/main/uboot-tools/defang-efi-bootcmd.patch
index 74182fdd10c..d7810093275 100644
--- a/main/uboot-tools/defang-efi-bootcmd.patch
+++ b/main/uboot-tools/defang-efi-bootcmd.patch
@@ -1,7 +1,7 @@
diff -urN u-boot-2019.10.orig/include/config_distro_bootcmd.h u-boot-2019.10/include/config_distro_bootcmd.h
--- u-boot-2019.10.orig/include/config_distro_bootcmd.h 2020-01-08 00:18:39.088623768 +0000
+++ u-boot-2019.10/include/config_distro_bootcmd.h 2020-01-08 00:19:27.963822184 +0000
-@@ -328,7 +328,8 @@
+@@ -334,7 +334,8 @@
#define BOOTENV_EFI_PXE_ARCH "0x1b"
#define BOOTENV_EFI_PXE_VCI "PXEClient:Arch:00027:UNDI:003000"
#elif defined(CONFIG_SANDBOX)