aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-10-09 23:21:38 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-10-10 05:55:13 +0000
commit0a7f97f20dac33b48ab36f8ff3292ebebc263220 (patch)
treeb3fe808f5e1f19c6e5f6022c2352ef3b9a338fcc
parentdf639a21ecd4bf7cbb18267373be055f9c06dae6 (diff)
testing/s3fs-fuse: upgrade to 1.87
-rw-r--r--testing/s3fs-fuse/APKBUILD9
-rw-r--r--testing/s3fs-fuse/define-SEEK.patch22
2 files changed, 28 insertions, 3 deletions
diff --git a/testing/s3fs-fuse/APKBUILD b/testing/s3fs-fuse/APKBUILD
index 03138c781f7..f2684467722 100644
--- a/testing/s3fs-fuse/APKBUILD
+++ b/testing/s3fs-fuse/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Steeve Chailloux <steeve.chailloux@orus.io>
# Maintainer: Steeve Chailloux <steeve.chailloux@orus.io>
pkgname=s3fs-fuse
-pkgver=1.86
+pkgver=1.87
pkgrel=0
pkgdesc="FUSE-based file system backed by Amazon S3"
options="!check" # Fails to connect to localhost
@@ -12,7 +12,9 @@ depends="fuse"
makedepends="automake autoconf libxml2-dev fuse-dev curl-dev git bash"
checkdepends="coreutils sed"
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/s3fs-fuse/s3fs-fuse/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/s3fs-fuse/s3fs-fuse/archive/v$pkgver.tar.gz
+ define-SEEK.patch
+ "
prepare() {
default_prepare
@@ -38,4 +40,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="a4f79d9ae526427d5d41b5cd1519e4aac605e8bbd97079aec2a67562f0322fa5664d770d565aed4fca83ae254ab3c0454d25f4b86ec4d148a57c7745e07f5e14 s3fs-fuse-1.86.tar.gz"
+sha512sums="654e96f080423b79403f31380157d3410f4f253648e6f024c271e3b48ec814c3373caf375ea6365e47f36b62cf602c9de1ab75b8e24d99dd37b19c158b12e5e1 s3fs-fuse-1.87.tar.gz
+31db7e7f31da53bb56a8cf51e246aef838e520375a39ae4517fe6af5a5a5fc3c092f6df63e9bfa59f3231a51dc1521aa2ae0881f9421da8324c1cd46a519b6f1 define-SEEK.patch"
diff --git a/testing/s3fs-fuse/define-SEEK.patch b/testing/s3fs-fuse/define-SEEK.patch
new file mode 100644
index 00000000000..4cd975ee688
--- /dev/null
+++ b/testing/s3fs-fuse/define-SEEK.patch
@@ -0,0 +1,22 @@
+Upstream: Not applicable
+Reason: Fixes compilation with musl
+
+diff --git a/src/fdcache.cpp b/src/fdcache.cpp
+index 6416b01..30e5a50 100644
+--- a/src/fdcache.cpp
++++ b/src/fdcache.cpp
+@@ -47,6 +47,14 @@
+ #include "curl.h"
+ #include "fdcache.h"
+
++// Taken from toybox portability
++// Introduced in Linux 3.1
++#ifndef SEEK_DATA
++#define SEEK_DATA 3
++#endif
++#ifndef SEEK_HOLE
++#define SEEK_HOLE 4
++#endif
+ using namespace std;
+
+ //------------------------------------------------