aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-04 17:42:06 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-04 17:42:06 -0300
commit0b00397fd0b6624b9deaa88ff7b2b5ff4ec6c1b9 (patch)
treef21e5d5f04ef437258b5733ba4e9cbac83e5d420
parent78256a2969081909bc2e31cc6367dbf7294d8d6c (diff)
community/elogind: add support for reloading
-rw-r--r--community/elogind/APKBUILD4
-rw-r--r--community/elogind/elogind.initd9
2 files changed, 11 insertions, 2 deletions
diff --git a/community/elogind/APKBUILD b/community/elogind/APKBUILD
index 9460219337d..13ef2389f76 100644
--- a/community/elogind/APKBUILD
+++ b/community/elogind/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Leo <thinkabit.ukim@gmail.com>
pkgname=elogind
pkgver=243.4
-pkgrel=3
+pkgrel=4
pkgdesc="Standalone fork of systemd's elogind"
url="https://github.com/elogind/elogind"
arch="all"
@@ -97,4 +97,4 @@ bashcomp() {
}
sha512sums="9751a3d0ed65dd73d9363097ee1752d437d5636db2a4137395596e0c81e04d4715f314568d1d7c6f367f1ecbda011086cb165bd4dc207302626b16e693cd0a02 elogind-243.4.tar.gz
-da03ea5d8805fa8c1cbb679ea067bd5b1542345f55882a80bd8633661bd360a5299023eae94ee6cde3ef9cfd9366d477f1894ae0f1371cca37ccebdc6cc7b94d elogind.initd"
+df3f56e5860ff2c1103a8f5512e0190c16838e5329b8eba4e77b9f18856be5503d03e3a1b2b3e9be07e5215981dd904f025f409da8440ecafc3ec43ae1e28fa4 elogind.initd"
diff --git a/community/elogind/elogind.initd b/community/elogind/elogind.initd
index 96626503e61..7563fe93098 100644
--- a/community/elogind/elogind.initd
+++ b/community/elogind/elogind.initd
@@ -3,6 +3,7 @@ supervisor=supervise-daemon
name="System login manager"
description="System service that manages user logins"
+description_reload="Reload configuration without exiting"
command=/usr/libexec/elogind/elogind
@@ -12,3 +13,11 @@ depend() {
# Make sure we start before any other display manager
before xdm lxdm sddm gdm
}
+
+extra_started_commands="reload"
+
+reload() {
+ ebegin "Reloading configuration"
+ $supervisor $RC_SVCNAME --signal HUP
+ eend $?
+}