aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2021-09-28 21:41:27 +0200
committerJakub Jirutka <jakub@jirutka.cz>2021-09-28 21:49:39 +0200
commit0bb77ff29da6227cd4c324470f0f9a6bbe14bbd7 (patch)
treedd7f6e757c29f2d15702df9ce85f0d1fdd1d0430
parent00d1ca05e322f2ffbda7c04b928a3a19f138e7a1 (diff)
community/jimtcl: build also shared lib and use it for jimsh
Resolves #13046
-rw-r--r--community/jimtcl/APKBUILD17
1 files changed, 15 insertions, 2 deletions
diff --git a/community/jimtcl/APKBUILD b/community/jimtcl/APKBUILD
index c7794d98f48..7085ab098d1 100644
--- a/community/jimtcl/APKBUILD
+++ b/community/jimtcl/APKBUILD
@@ -27,17 +27,27 @@ prepare() {
# tty tests fail on builders - no tty available there.
rm tests/tty.test
+
+ cp -r "$builddir" "$builddir-static"
}
build() {
+ _build --shared
+
+ cd "$builddir-static"
+ _build
+}
+
+_build() {
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--docdir=/usr/share/doc/$pkgname \
--full \
- --with-mod=sqlite3,readline,rlprompt
- make
+ --with-mod=sqlite3,readline,rlprompt \
+ "$@"
+ make -j1
}
check() {
@@ -46,6 +56,9 @@ check() {
package() {
make install DESTDIR="$pkgdir"
+ ln -s /usr/lib/libjim.so.$pkgver "$pkgdir"/usr/lib/libjim.so
+
+ install -m644 "$builddir-static"/libjim.a -t "$pkgdir"/usr/lib/
}
readline() {