aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Polański <michal@polanski.me>2020-08-28 19:13:34 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-08-28 19:06:34 +0000
commit1068dad184bea055a0730adbbc7c2159f18a7ad2 (patch)
tree4f75bda7b18dbcd324076a5426d8b6135c72dc78
parentd652535262e95efe6181978e6b5645ba09ad7b8e (diff)
testing/py3-rarfile: fix tests
-rw-r--r--testing/py3-rarfile/APKBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/testing/py3-rarfile/APKBUILD b/testing/py3-rarfile/APKBUILD
index a68aa7c44dd..700a9aed3e0 100644
--- a/testing/py3-rarfile/APKBUILD
+++ b/testing/py3-rarfile/APKBUILD
@@ -3,15 +3,14 @@
pkgname=py3-rarfile
_pyname=rarfile
pkgver=4.0
-pkgrel=0
+pkgrel=1
pkgdesc="RAR archive reader"
-options="!check" # 3 tests fail
url="https://github.com/markokr/rarfile"
arch="noarch"
license="ISC"
depends="python3"
makedepends="py3-setuptools"
-checkdepends="py3-nose unrar"
+checkdepends="py3-pytest unrar libarchive-tools"
source="https://files.pythonhosted.org/packages/source/${_pyname:0:1}/$_pyname/$_pyname-$pkgver.tar.gz"
builddir="$srcdir"/$_pyname-$pkgver
@@ -23,7 +22,8 @@ build() {
}
check() {
- nosetests-3.7
+ # unar is not packaged in Alpine
+ pytest -k "not test_unar_tool"
}
package() {