aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-09-26 07:46:59 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-09-26 07:46:59 +0000
commit113e3cc1781bee7bcaed2de514d8b852edd12b6c (patch)
tree694e94f2924978830a881ecc7f042089cf0a1d1b
parent6f01aefa8951cd83e0e88afcdeb3e40e892518a7 (diff)
/main/newt: upgrade to 0.52.20, added py3 subpackage
-rw-r--r--main/newt/APKBUILD24
1 files changed, 15 insertions, 9 deletions
diff --git a/main/newt/APKBUILD b/main/newt/APKBUILD
index 555176830bf..70f0a55588c 100644
--- a/main/newt/APKBUILD
+++ b/main/newt/APKBUILD
@@ -1,14 +1,13 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=newt
-pkgver=0.52.19
+pkgver=0.52.20
pkgrel=0
pkgdesc="Redhat's Newt windowing toolkit development files"
url="https://pagure.io/newt/"
arch="all"
license="LGPL2"
-depends=
-makedepends="slang-dev popt-dev python2-dev ncurses-dev"
-subpackages="$pkgname-dev $pkgname-doc py-newt:py $pkgname-lang"
+makedepends="slang-dev popt-dev python2-dev python3-dev ncurses-dev"
+subpackages="$pkgname-dev $pkgname-doc py-newt:py2 py3-newt:py3 $pkgname-lang"
source="https://releases.pagure.org/newt/newt-$pkgver.tar.gz
parallel-build.patch
fix-includes.patch"
@@ -18,7 +17,7 @@ builddir="$srcdir/$pkgname-$pkgver"
prepare() {
cd "$builddir"
sed -i -e 's:-lslang:-lslang -lncurses:g' \
- -e 's:instroot:DESTDIR:g' Makefile.in || return 1
+ -e 's:instroot:DESTDIR:g' Makefile.in
}
build() {
@@ -30,7 +29,7 @@ build() {
--without-tcl \
--disable-nls \
|| return 1
- make RPM_OPT_FLAGS="$CFLAGS" || return 1
+ make RPM_OPT_FLAGS="$CFLAGS"
}
package() {
@@ -40,12 +39,19 @@ package() {
|| true
}
-py() {
+py2() {
pkgdesc="A NEWT module for Python2"
mkdir -p "$subpkgdir"/usr/lib/
- mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
+ mv "$pkgdir"/usr/lib/python2.7 "$subpkgdir"/usr/lib/
}
-sha512sums="a71b3ea69e09f348f6f883c9c3cccf3743e986858235e3df1c85e28d74605a1f822bc35c9450c473efe7e6b5f252d2b5a12e11b2023463e9803916ff09b42834 newt-0.52.19.tar.gz
+
+py3() {
+ pkgdesc="A NEWT module for Python3"
+ mkdir -p "$subpkgdir"/usr/lib/
+ mv "$pkgdir"/usr/lib/python3.6 "$subpkgdir"/usr/lib/
+}
+
+sha512sums="0c10c373c6a5299a85fc38f32d3590fff3b26c4be40e6c85ed73c20724ef2fb094bf37a8c3b1b80a4bcdfc14fe59254d4419c391245c298a4e16788954b88236 newt-0.52.20.tar.gz
ea3937142ce776b6c227936e87f7bc28116ab7775db5785600e39bee38eba914d3ccae1ecb54d9f4ac9505918da255d69a777b105d80d72cd087545b1dae18bc parallel-build.patch
ce53446eb587b79790f12f806f02999568cb49067520813ab146d1f16c71f009e86ab72d08666e483b550fdae3332b673935b8aa1a14b02f5273217fb5404611 fix-includes.patch"