aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoseph Benden <joe@benden.us>2019-07-17 23:34:58 +0000
committerLeo <thinkabit.ukim@gmail.com>2019-07-21 01:11:34 -0300
commit12229e03d32b3cab20e6e136fda5cc1b749372a7 (patch)
tree4143d4bd8ffc291da185bb71cb5d389e39f4e308
parentb7800e184a122f9eafa41fd0298fa144894edd7a (diff)
testing/topgit: new aport
https://github.com/mackyle/topgit A different patch queue manager Signed-off-by: Joseph Benden <joe@benden.us>
-rw-r--r--testing/topgit/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/topgit/APKBUILD b/testing/topgit/APKBUILD
new file mode 100644
index 00000000000..e3eada24c61
--- /dev/null
+++ b/testing/topgit/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Joseph Benden <joe@benden.us>
+# Maintainer: Joseph Benden <joe@benden.us>
+
+pkgname=topgit
+pkgver=0.19.12
+pkgrel=0
+pkgdesc="A different patch queue manager"
+arch="noarch"
+url="https://github.com/mackyle/topgit"
+license="GPL-2.0-or-later"
+options="!check"
+depends="git gawk sed"
+makedepends="perl"
+subpackages="$pkgname-doc"
+source="${pkgname}-${pkgver}.tar.gz::$url/archive/${pkgname}-${pkgver}.tar.gz"
+builddir="$srcdir/${pkgname}-${pkgname}-$pkgver"
+
+build() {
+ make prefix=/usr sharedir=/usr/share/doc/$pkgname
+}
+
+package() {
+ make DESTDIR="$pkgdir" prefix=/usr sharedir=/usr/share/doc/$pkgname install
+ # TODO: install bash completions
+}
+
+sha512sums="cb9245fbec7a4a15822a5b70d7052be200aa8b574b528dd929121597eb7dcec97532b0fd4d6a4d6bb63676194ed0ab2129e106fb88f63561187620ec431f9efb topgit-0.19.12.tar.gz"