aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2021-06-09 16:35:43 -0300
committerLeo <thinkabit.ukim@gmail.com>2021-06-09 20:04:24 +0000
commit1481902efddbafea5eb144cca14fa31dd47c1d5f (patch)
tree908e1235365eec8f514fc2c16d06dc530d4280de
parentcbeadb1e1c46a520e71907d43c729a63fa11fa7c (diff)
main/dtc: upgrade to 1.6.1
-rw-r--r--main/dtc/APKBUILD15
-rw-r--r--main/dtc/increase_max_srcfile_depth.patch15
2 files changed, 8 insertions, 22 deletions
diff --git a/main/dtc/APKBUILD b/main/dtc/APKBUILD
index 57b7ffbfeda..4b7c228f812 100644
--- a/main/dtc/APKBUILD
+++ b/main/dtc/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=dtc
-pkgver=1.6.0
-pkgrel=3
+pkgver=1.6.1
+pkgrel=0
pkgdesc="Device Tree Compiler"
url="https://git.kernel.org/pub/scm/utils/dtc/dtc.git/"
arch="all"
@@ -10,8 +10,8 @@ makedepends="bison flex python3-dev swig"
checkdepends="coreutils"
subpackages="$pkgname-dev libfdt py3-libfdt:py3_libfdt"
source="https://kernel.org/pub/software/utils/dtc/dtc-$pkgver.tar.xz
- increase_max_srcfile_depth.patch
- install-pylibfdt-to-destdir.patch"
+ install-pylibfdt-to-destdir.patch
+ "
prepare() {
default_prepare
@@ -42,6 +42,7 @@ py3_libfdt() {
amove usr/lib/python3*
}
-sha512sums="15433b24f1d6b7ed1f8066d050bd1bcbf988731aa38147564e3dd04b5f69af8d69e03befdc621a768526c620425a9bdd24aad4f9ff135930d6a1eeb0625f7de3 dtc-1.6.0.tar.xz
-d30b04d6c177578f000465654d1bb0ebe4509fb290842f14d4dbdcd7c0bbdc8f2c8c73cfac2fc87a1896e17352652090cbac46c4e8d62c4e8cb97d5e9bd99647 increase_max_srcfile_depth.patch
-1c43dfae8d15861c4f0170f0df9ba63d197ab3be50e39fe5748e547074c52dc7b042ca5e9c64d3d4bb0a8e8cde8df7e71660cde93e9512923405c38debcaa01c install-pylibfdt-to-destdir.patch"
+sha512sums="
+26cd351ddca411ab96b93ac3e763f817f9f8a80ca66a8707e1077f771ed8e7e04c01f321ab8ab27b2f9826d9d438483fe3156401493bfd29cef3cc71a1414568 dtc-1.6.1.tar.xz
+1c43dfae8d15861c4f0170f0df9ba63d197ab3be50e39fe5748e547074c52dc7b042ca5e9c64d3d4bb0a8e8cde8df7e71660cde93e9512923405c38debcaa01c install-pylibfdt-to-destdir.patch
+"
diff --git a/main/dtc/increase_max_srcfile_depth.patch b/main/dtc/increase_max_srcfile_depth.patch
deleted file mode 100644
index c821dcde4ba..00000000000
--- a/main/dtc/increase_max_srcfile_depth.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Upstream dtc has MAX_SRCFILE_DEPTH set to 100 in srcpos.c, which is max number of includes set to prevent infinite recursion.
-Unfortunately some kernels require this number to be bigger, and since it's just a sanity check to detect infinite recursion it shouldn't hurt increasing it to 200.
-diff --git a/srcpos.c b/srcpos.c
-index f5205fb..4fdb22a 100644
---- a/srcpos.c
-+++ b/srcpos.c
-@@ -20,7 +20,7 @@ struct search_path {
- static struct search_path *search_path_head, **search_path_tail;
-
- /* Detect infinite include recursion. */
--#define MAX_SRCFILE_DEPTH (100)
-+#define MAX_SRCFILE_DEPTH (200)
- static int srcfile_depth; /* = 0 */
-
- static char *get_dirname(const char *path)