aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-07-13 18:48:37 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-07-13 17:14:31 +0000
commit153daf6cc0400417b7a1f0de8a4c7eace7216341 (patch)
tree2d2e3218a401c29bd0fc43333e83b3ed9fe3855e
parente60f3cd971c1cbd33bf363fb92b3b2b03ed93485 (diff)
main/libinput: move quirks and udev rules to -libs subpkg
These files are required for any device which may differ from vendor to vendor, e.g. trackpads
-rw-r--r--main/libinput/APKBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/main/libinput/APKBUILD b/main/libinput/APKBUILD
index 23bada46ee1..1d0834a946b 100644
--- a/main/libinput/APKBUILD
+++ b/main/libinput/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Daniel Sabogal <dsabogalcc@gmail.com>
pkgname=libinput
pkgver=1.15.6
-pkgrel=0
+pkgrel=1
pkgdesc="Library for handling input devices"
url="https://www.freedesktop.org/wiki/Software/libinput"
arch="all"
@@ -39,6 +39,14 @@ package() {
DESTDIR="$pkgdir" ninja -C builddir/ install
}
+libs() {
+ default_libs
+
+ mv "$pkgdir"/usr/lib/udev "$subpkgdir"/usr/lib
+ mkdir -p "$subpkgdir"/usr/share/
+ mv "$pkgdir"/usr/share/libinput "$subpkgdir"/usr/share
+}
+
zshcomp() {
depends=""
pkgdesc="Zsh completions for $pkgname"