aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-14 12:38:28 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-14 12:38:39 -0300
commit165cc9f46d1c8c38547c0cc72953811da82b7462 (patch)
tree752daca1ab49164bc2c90602e018d44d97ef4c9f
parent822b8f4867fcb027e8d8a3114584dccdf7a65f99 (diff)
main/http-parser: disable tests on 32bit arm arches
-rw-r--r--main/http-parser/APKBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/main/http-parser/APKBUILD b/main/http-parser/APKBUILD
index 5540cd94806..8fddc1b1a03 100644
--- a/main/http-parser/APKBUILD
+++ b/main/http-parser/APKBUILD
@@ -8,7 +8,14 @@ url="https://github.com/nodejs/http-parser"
arch="all"
license="MIT"
subpackages="$pkgname-dev"
-source="https://github.com/nodejs/http-parser/archive/v$pkgver/$pkgname-$pkgver.tar.gz"
+source="https://github.com/nodejs/http-parser/archive/v$pkgver/http-parser-$pkgver.tar.gz"
+
+case "$CARCH" in
+ armhf|armv7)
+ # Tests fail due to padding
+ options="$options !check"
+ ;;
+esac
build() {
make library