aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimothy Legge <timlegge@gmail.com>2020-08-19 23:37:52 +0000
committerLeo <thinkabit.ukim@gmail.com>2020-09-21 23:36:21 +0000
commit16c0ca59e2fa290aaeff352d9366168a6a112e86 (patch)
treeda2050c5f98f1ca490bb2b6147a4ba17072ca77b
parent5026a5c7d73bec4da7bca8f0654c27c1c9d2b8d0 (diff)
testing/perl-test-allmodules: new aport
-rw-r--r--testing/perl-test-allmodules/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/perl-test-allmodules/APKBUILD b/testing/perl-test-allmodules/APKBUILD
new file mode 100644
index 00000000000..c939f51e632
--- /dev/null
+++ b/testing/perl-test-allmodules/APKBUILD
@@ -0,0 +1,34 @@
+# Automatically generated by apkbuild-cpan, template 3
+# Contributor: Timothy Legge <timlegge@gmail.com>
+# Maintainer: Timothy Legge <timlegge@gmail.com>
+pkgname=perl-test-allmodules
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
+_pkgreal=Test-AllModules
+pkgver=0.17
+pkgrel=0
+pkgdesc="do some tests for modules in search path"
+url="https://metacpan.org/release/Test-AllModules/"
+arch="noarch"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl perl-module-pluggable perl-test-sharedfork"
+makedepends="perl-dev perl-module-build perl-module-build"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/B/BA/BAYASHI/Test-AllModules-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ perl Build.PL --installdirs=vendor
+ ./Build
+}
+
+check() {
+ ./Build test
+}
+
+package() {
+ ./Build install --destdir="$pkgdir"
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="ed753967ec30f5b1742622228aa219aa1de073fe8956e974d7ba3eb7eeeaedf2989de8159e94eef6e4659b63521e1dd57be5159fa4309aa26e739c1b85ae4b90 Test-AllModules-0.17.tar.gz"