aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-04-22 01:32:11 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-04-22 01:32:57 +0200
commit18271ca719e6f8b109e3fd69eac2b2c361db3f39 (patch)
treeece29f98af4c686823a52c33f864fbe343cd499b
parentf61f100a23db3cec331a3831fd251706daacee34 (diff)
community/lensfun: improve abuild
-rw-r--r--community/lensfun/APKBUILD36
1 files changed, 18 insertions, 18 deletions
diff --git a/community/lensfun/APKBUILD b/community/lensfun/APKBUILD
index 955b9c33245..3d8ef415d4b 100644
--- a/community/lensfun/APKBUILD
+++ b/community/lensfun/APKBUILD
@@ -3,38 +3,38 @@
pkgname=lensfun
pkgver=0.3.2
pkgrel=0
-pkgdesc="Image manipulation library to rectify lens defects."
+pkgdesc="Image manipulation library to rectify lens defects"
url="http://lensfun.sourceforge.net/"
arch="all"
license="LGPL3"
-depends=""
-depends_dev=""
makedepends="py-docutils cmake doxygen libpng glib-dev"
-install=""
subpackages="$pkgname-dev"
-source="http://downloads.sourceforge.net/project/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz"
-builddir=${srcdir}/${pkgname}-${pkgver}
+source="http://downloads.sourceforge.net/project/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
- local opts=
+
+ local opts=""
case "$CARCH" in
- x86*) ;;
- *) opts="-DBUILD_FOR_SSE=OFF -DBUILD_FOR_SSE2=OFF";;
+ x86*) ;;
+ *) opts="-DBUILD_FOR_SSE=OFF -DBUILD_FOR_SSE2=OFF";;
esac
- cmake \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- $opts \
- || return 1
- make all || return 1
+
+ cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ $opts \
+ || return 1
+
+ make all
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install
- }
+ make DESTDIR="$pkgdir" install
+}
md5sums="247e59a0812ec451f6cd0d20b3379cb5 lensfun-0.3.2.tar.gz"
sha256sums="ae8bcad46614ca47f5bda65b00af4a257a9564a61725df9c74cb260da544d331 lensfun-0.3.2.tar.gz"