aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2021-02-08 00:03:50 -0300
committerLeo <thinkabit.ukim@gmail.com>2021-02-08 03:29:56 +0000
commit187fe7b33e781dd7a77d69c62ab7b958aa304b65 (patch)
tree90ec419534e60f293e643f18b92dd022e4c9af12
parent848ac411aeacba8fbd596fd3c900d5008ecacab2 (diff)
community/accountsservice: fix location of dbus configuration
-rw-r--r--community/accountsservice/APKBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/community/accountsservice/APKBUILD b/community/accountsservice/APKBUILD
index 4a554b86d32..8a3e341f106 100644
--- a/community/accountsservice/APKBUILD
+++ b/community/accountsservice/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=accountsservice
pkgver=0.6.55
-pkgrel=1
+pkgrel=2
pkgdesc="D-Bus interface for user account query and manipulation"
options="!check" # No testsuite
url="https://www.freedesktop.org/software/accountsservice/"
@@ -21,6 +21,14 @@ source="https://www.freedesktop.org/software/accountsservice/accountsservice-$pk
musl-wtmp.patch
"
+prepare() {
+ default_prepare
+ # Fix location of dbus configuration, it should look at our datadir
+ # (/usr/share) not the sysconfdir (/etc) which is reserved for
+ # local admins
+ sed -i '/dbus_conf_dir/s/sysconfdir/datadir/g' meson.build
+}
+
build() {
abuild-meson \
-Dsystemdsystemunitdir=no \