aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoralpine-mips-patches <info@mobile-stream.com>2018-12-19 07:44:45 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-12-19 12:37:21 +0000
commit18aa08c946b29cb674fc5103f65672d8475ad18e (patch)
treed42298332992bf085e8de2efa8342b367092064a
parent3f3385cfb78f7ce5fed1e51ee6ce2dfe8c2c2c55 (diff)
community/libreswan: do not use local copy of CERT_CompareAVA
As lib/libswan/nss_copies.c says: /* * The NSS function CERT_CompareAVA() appears in the NSS header files, * but the library does not actually export the function. This is a copy * of that function until upstream NSS is fixed and the fix available in * the common Linux distributions. This workaround is enabled using * NSS_REQ_AVA_COPY=true * * See also: * https://bugzilla.mozilla.org/show_bug.cgi?id=1336487 * https://bugzilla.mozilla.org/show_bug.cgi?id=294538 */ So disable the work-around on Alpine since main/nss is new enough. This is also a build fix for mips* as nss_copies.c expects that libc provides <sgidefs.h> in the standard location.
-rw-r--r--community/libreswan/APKBUILD4
-rw-r--r--community/libreswan/Makefile.inc.local1
2 files changed, 3 insertions, 2 deletions
diff --git a/community/libreswan/APKBUILD b/community/libreswan/APKBUILD
index 87a87318f57..66c99cc4991 100644
--- a/community/libreswan/APKBUILD
+++ b/community/libreswan/APKBUILD
@@ -2,7 +2,7 @@
pkgname=libreswan
pkgver=3.27
-pkgrel=0
+pkgrel=1
pkgdesc="IPsec implementation for Linux"
url="https://libreswan.org"
arch="all"
@@ -45,4 +45,4 @@ package() {
}
sha512sums="b92ecfd08b9d19dc801032176eff3dd07f625223d4f0dd07ff10f639644573430a55f7aebfcc8b9d2424e194ca9d06b17ad5a13dad5dc6f659d19bc5d32520f5 libreswan-3.27.tar.gz
df503e349661a029f8f6569ea65b4ecceb67f18c0a133d4818d390c0e6e719c2c793c483881778685f1eedaa210ea815ae4f77a94fa84a1acb63a9ad5e8db501 fix-includes.patch
-8c80e5dc8b1b9ac2cd9c3441da2a4253d23328a065655d85f7958ec0678bd42fc74b418524a4787075872c0f545e8fb0394ff168cd25d1dc49010248155ddaef Makefile.inc.local"
+36415fae9b6674d66b7728fbc1df4bb3c4fcb16f0bbe88ead1f23e553bb51a9deb288a8659a0050a3fb1e14c3dbb8fb8524e9ef48fb6842dc94b11b758349c58 Makefile.inc.local"
diff --git a/community/libreswan/Makefile.inc.local b/community/libreswan/Makefile.inc.local
index 5be1fb6421b..348ca6447ba 100644
--- a/community/libreswan/Makefile.inc.local
+++ b/community/libreswan/Makefile.inc.local
@@ -1,2 +1,3 @@
+NSS_REQ_AVA_COPY=false
USE_GLIBC_KERN_FLIP_HEADERS=true
USE_LABELED_IPSEC=false