aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-04-28 17:27:12 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2020-04-29 15:11:05 +0000
commit18d0bbdfeb2b42e88f8c63d3569edb8e3e7f5e27 (patch)
treec1225243cc2430e1d6aed284b66baf508c120ce2
parenta99a48682f14d0bd7b2cb2a567f6f008e068bc70 (diff)
community/audacious-plugins: disable QtGLSpectrum plugin on arm*
This enables us to build Qt5 with OpenGLES rather than OpenGL on ARM platforms
-rw-r--r--community/audacious-plugins/APKBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/community/audacious-plugins/APKBUILD b/community/audacious-plugins/APKBUILD
index 669b39a21fb..a02440fce88 100644
--- a/community/audacious-plugins/APKBUILD
+++ b/community/audacious-plugins/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Ariadne Conill <ariadne@dereferenced.org>
pkgname=audacious-plugins
pkgver=4.0.2
-pkgrel=0
+pkgrel=1
pkgdesc="A playlist-oriented media player with multiple interfaces (plugins)"
url="https://audacious-media-player.org/"
arch="all !s390x"
@@ -40,8 +40,13 @@ makedepends="
autoconf
"
subpackages="$pkgname-lang $pkgname-dbg"
-source="http://distfiles.audacious-media-player.org/$pkgname-$pkgver.tar.bz2"
-options="!check" # No test suite (or any plans for one)
+source="http://distfiles.audacious-media-player.org/audacious-plugins-$pkgver.tar.bz2"
+options="!check" # No test suite (or any plans for one)
+
+case "$CTARGET_ARCH" in
+ arm*|aarch64) _qtglspectrum="--disable-qtglspectrum" ;;
+ *) _qtglspectrum="--enable-qtglspectrum" ;;
+esac
build() {
./configure \
@@ -52,7 +57,8 @@ build() {
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--disable-gtk \
- --enable-qt
+ --enable-qt \
+ $_qtglspectrum
make
}