aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2017-09-06 02:51:21 -0500
committerNatanael Copa <ncopa@alpinelinux.org>2017-09-19 10:54:40 +0000
commit18e166478e2592cedc3869d63361dc3569ddc09b (patch)
tree9f3074354fd6c6290a26404cae61a73543970be1
parente9a7a8c53125f6cd6fa5454788b92e7821ed9479 (diff)
main/encodings: modernise, fix deps, no test
-rw-r--r--main/encodings/APKBUILD25
1 files changed, 11 insertions, 14 deletions
diff --git a/main/encodings/APKBUILD b/main/encodings/APKBUILD
index 7f78fe7d398..a2fad29e7a9 100644
--- a/main/encodings/APKBUILD
+++ b/main/encodings/APKBUILD
@@ -1,38 +1,35 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=encodings
pkgver=1.0.4
-pkgrel=0
+pkgrel=1
pkgdesc="X.org font encoding files"
url="http://xorg.freedesktop.org/"
arch="noarch"
license="custom"
+options="!check" # No test suite.
depends=
-makedepends="mkfontscale"
+makedepends="mkfontscale util-macros"
install=
source="http://www.x.org/releases/individual/font/encodings-$pkgver.tar.bz2"
-_builddir="$srcdir/$pkgname-$pkgver"
-
prepare() {
- cd "$_builddir"
- update_config_sub || return 1
+ cd "$builddir"
+ update_config_sub
+ default_prepare
}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
- --with-encodingsdir=/usr/share/fonts/encodings \
- || return 1
- make || return 1
+ --with-encodingsdir=/usr/share/fonts/encodings
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
}
-md5sums="0f2d6546d514c5cc4ecf78a60657a5c1 encodings-1.0.4.tar.bz2"
-sha256sums="ced6312988a45d23812c2ac708b4595f63fd7a49c4dcd9f66bdcd50d1057d539 encodings-1.0.4.tar.bz2"
sha512sums="838d1c9489e9880bf1982dc14d34a48b624b7bc2c0fffbf28e2c24e1546b0602357ca31afef100053481d6a18e357085ef74ac7a82261daa1ac1398bc1e05d17 encodings-1.0.4.tar.bz2"