aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Adamski <michal@ert.pl>2020-08-10 16:42:15 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-08-10 15:15:52 +0000
commit192cf0d83a7ed7eeac6a806ce8f9c439b09385d1 (patch)
tree406c783bd50144d3c5cd29aa580d2e5f18c3546d
parent707b13c8ad62118f11d71d8deecf9c0f3899b341 (diff)
testing/py3-bitstring: new aport
-rw-r--r--testing/py3-bitstring/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/py3-bitstring/APKBUILD b/testing/py3-bitstring/APKBUILD
new file mode 100644
index 00000000000..2dc02e5c8de
--- /dev/null
+++ b/testing/py3-bitstring/APKBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Michał Adamski <michal@ert.pl>
+pkgname=py3-bitstring
+pkgver=3.1.7
+pkgrel=0
+pkgdesc="Simple construction, analysis and modification of binary data."
+url="https://github.com/scott-griffiths/bitstring"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/b/bitstring/bitstring-$pkgver.tar.gz"
+builddir="$srcdir/bitstring-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py check
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+sha512sums="3c05222b6a6a885664adebb1ea455ef4e199c91698b89bc136a7d3f5f7ceb38868c9883509ba4067c163e1521f85c36abbff9763a590cbfa99705fd08d2a6a6f bitstring-3.1.7.tar.gz"