aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2020-08-26 23:10:20 +0300
committerTimo Teräs <timo.teras@iki.fi>2020-08-26 23:10:20 +0300
commit19b45c634d27ea0ce5bc37647f91341a443411bd (patch)
treec995b5b6721c62a3b10a16b7f50775059c43510c
parent16569f1e82ea12cfea32c64fd539f6e08440ad92 (diff)
main/apk-tools: fix --repository short option
fixes #10707
-rw-r--r--main/apk-tools/0002-fix-repository-short-option-to-be-X-as-before.patch27
-rw-r--r--main/apk-tools/APKBUILD6
2 files changed, 31 insertions, 2 deletions
diff --git a/main/apk-tools/0002-fix-repository-short-option-to-be-X-as-before.patch b/main/apk-tools/0002-fix-repository-short-option-to-be-X-as-before.patch
new file mode 100644
index 00000000000..7319569010d
--- /dev/null
+++ b/main/apk-tools/0002-fix-repository-short-option-to-be-X-as-before.patch
@@ -0,0 +1,27 @@
+From fb0109fdb199436979af71b3d8f973dbbf4fb906 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
+Date: Wed, 26 Aug 2020 23:03:48 +0300
+Subject: [PATCH] fix --repository short option to be -X as before
+
+unintentional regression from commit edb45ae464
+fixes #10707
+---
+ src/apk.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/apk.c b/src/apk.c
+index a315edc..4aba0a6 100644
+--- a/src/apk.c
++++ b/src/apk.c
+@@ -97,7 +97,7 @@ static struct apk_repository_list *apk_repository_new(const char *url)
+ OPT(OPT_GLOBAL_purge, "purge") \
+ OPT(OPT_GLOBAL_quiet, APK_OPT_SH("q") "quiet") \
+ OPT(OPT_GLOBAL_repositories_file, APK_OPT_ARG "repositories-file") \
+- OPT(OPT_GLOBAL_repository, APK_OPT_ARG APK_OPT_SH("x") "repository") \
++ OPT(OPT_GLOBAL_repository, APK_OPT_ARG APK_OPT_SH("X") "repository") \
+ OPT(OPT_GLOBAL_root, APK_OPT_ARG APK_OPT_SH("p") "root") \
+ OPT(OPT_GLOBAL_update_cache, APK_OPT_SH("U") "update-cache") \
+ OPT(OPT_GLOBAL_verbose, APK_OPT_SH("v") "verbose") \
+--
+2.28.0
+
diff --git a/main/apk-tools/APKBUILD b/main/apk-tools/APKBUILD
index 76a2345f3ea..fac25ece463 100644
--- a/main/apk-tools/APKBUILD
+++ b/main/apk-tools/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=apk-tools
pkgver=2.12.0_rc1
-pkgrel=1
+pkgrel=2
pkgdesc="Alpine Package Keeper - package manager for alpine"
arch="all"
url="https://gitlab.alpinelinux.org/alpine/apk-tools"
@@ -19,6 +19,7 @@ if [ "$CBUILD" = "$CHOST" ]; then
fi
source="https://gitlab.alpinelinux.org/alpine/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz
0001-build-make-soname-explicit-and-simplify-and-fix-sona.patch
+ 0002-fix-repository-short-option-to-be-X-as-before.patch
"
builddir="$srcdir/$pkgname-v$pkgver"
@@ -75,4 +76,5 @@ luaapk() {
}
sha512sums="27afe59207fc642aff2e86f75520a52c78d7748ca9f10f3d74f2bca163c1e9741c51d0657d1b46a65fd14255b23c3a0cbc913712708ef5809667ac7990c84063 apk-tools-v2.12.0_rc1.tar.gz
-7b4fb78e1722212d31418e2fd72b2023339cebf9041f0071eac4df2cd7364218b338b703247a8246f5b781c28640a2b9a569f83f9c920fa5a9de64616e7b9edf 0001-build-make-soname-explicit-and-simplify-and-fix-sona.patch"
+7b4fb78e1722212d31418e2fd72b2023339cebf9041f0071eac4df2cd7364218b338b703247a8246f5b781c28640a2b9a569f83f9c920fa5a9de64616e7b9edf 0001-build-make-soname-explicit-and-simplify-and-fix-sona.patch
+af2babedba583058da62e01651c167afaa6633eb59489a2afe349d700803f127330ad89d3762ab71dd81065728d2263ef6e971732d73ae07c2273ddfc3e16033 0002-fix-repository-short-option-to-be-X-as-before.patch"