aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-05-07 10:29:41 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-05-07 09:24:16 +0000
commit19ea6c2233735b988d2a563c004c69555fd92983 (patch)
treec355074d73850c66fd33fa8e348e33c24251d9ec
parent8d77f932894589b1f3e20b4e48915ecdc4e6bbcb (diff)
testing/py3-precise-runner: upgrade to 0.3.1
-rw-r--r--testing/py3-precise-runner/APKBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/testing/py3-precise-runner/APKBUILD b/testing/py3-precise-runner/APKBUILD
index 5ed92a123ae..95b5799b255 100644
--- a/testing/py3-precise-runner/APKBUILD
+++ b/testing/py3-precise-runner/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-precise-runner
-pkgver=0.2.1
+pkgver=0.3.1
pkgrel=0
pkgdesc="A lightweight, simple-to-use, RNN wake word listener "
url="https://github.com/MycroftAI/mycroft-precise"
@@ -9,8 +9,8 @@ arch="noarch !mips !mips64 !s390x" # Blocked by py3-bbopt
license="Apache-2.0"
depends="python3 py3-bbopt py3-fitipy py3-pyaudio"
makedepends="py3-setuptools"
+checkdepends="py3-pytest"
source="https://pypi.python.org/packages/source/p/precise-runner/precise-runner-$pkgver.tar.gz"
-options="!check" # No tests
builddir="$srcdir/precise-runner-$pkgver"
build() {
@@ -18,11 +18,11 @@ build() {
}
check() {
- python3 setup.py test
+ PYTHONPATH="$PWD/build/lib" pytest
}
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="1ba39f8ca1c8ce00d02794e0bfb1890d6f376e60cd190bd773da8bab7cfc92ea14ce60b01eb08755da16d44e170295b6a66611b2aa532d70609677984bce44a2 precise-runner-0.2.1.tar.gz"
+sha512sums="58c62992666322018c01a22916b3a1014002c7aceda830970f1d0330777b47c981810f5a6a05840695b032cba21c8df09d14b982b24fac3926551a15a8dd99fd precise-runner-0.3.1.tar.gz"