aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2021-02-08 17:49:06 -0300
committerLeo <thinkabit.ukim@gmail.com>2021-02-08 17:49:06 -0300
commit1b271aa0d38cca389cd6bf02bc0a42f3a60186de (patch)
treef1712ec89769248306ac57992c31d99afcaed889
parenta9a564162e14a6196da350c4c5eb887b4e307ea8 (diff)
main/py3-future: drop dep on py3-setuptools
-rw-r--r--main/py3-future/APKBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/main/py3-future/APKBUILD b/main/py3-future/APKBUILD
index cff10424452..57bc5c23dcf 100644
--- a/main/py3-future/APKBUILD
+++ b/main/py3-future/APKBUILD
@@ -3,12 +3,14 @@
pkgname=py3-future
_pkgname=future
pkgver=0.18.2
-pkgrel=1
+pkgrel=2
pkgdesc="Easy, clean, reliable Python 2/3 compatibility"
url="http://python-future.org/"
arch="noarch"
license="MIT"
-depends="python3 py3-setuptools"
+depends="python3"
+# It can be built without it but it misses a lot of functionality
+makedepends="py3-setuptools"
source="$pkgname-$pkgver.tar.gz::https://pypi.io/packages/source/f/future/future-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -16,12 +18,10 @@ replaces="py-future" # Backwards compatibility
provides="py-future=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
python3 setup.py check
}