aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2020-12-27 11:14:02 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2020-12-27 11:15:37 +0000
commit1bdc89618fa13cd5d301d6374962cd4444a1fb5f (patch)
tree27580a40be58b3c53b88fb26aec23c4f210d911b
parent3cff4a66e672e14c8cc4969f7d202032a253cb84 (diff)
community/graphicsmagick: upgrade to 1.3.36
-rw-r--r--community/graphicsmagick/APKBUILD10
-rw-r--r--community/graphicsmagick/CVE-2020-12672.patch49
2 files changed, 4 insertions, 55 deletions
diff --git a/community/graphicsmagick/APKBUILD b/community/graphicsmagick/APKBUILD
index ddaf9937d00..24c6e9165e0 100644
--- a/community/graphicsmagick/APKBUILD
+++ b/community/graphicsmagick/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=graphicsmagick
-pkgver=1.3.35
-pkgrel=2
+pkgver=1.3.36
+pkgrel=0
pkgdesc="Image processing system"
url="http://www.graphicsmagick.org/"
arch="all"
@@ -10,8 +10,7 @@ license="MIT"
makedepends="libpng-dev tiff-dev libxml2-dev libwmf-dev freetype-dev libtool libltdl
libwebp-dev"
subpackages="$pkgname-dev $pkgname-doc"
-source="https://downloads.sourceforge.net/graphicsmagick/graphicsmagick/$pkgver/GraphicsMagick-$pkgver.tar.xz
-CVE-2020-12672.patch"
+source="https://downloads.sourceforge.net/graphicsmagick/graphicsmagick/$pkgver/GraphicsMagick-$pkgver.tar.xz"
options="libtool !check"
builddir="$srcdir"/GraphicsMagick-$pkgver
@@ -147,5 +146,4 @@ package() {
make -j1 DESTDIR="$pkgdir" install
}
-sha512sums="baae92089d52147ef961f93495abc8a9d8b1a963af61d87a650c1ab105d46816aa38c83f654edcb5a0e1b7f07ccc06eaeaa443b9bde3a63a0b9bfb45f3ae144c GraphicsMagick-1.3.35.tar.xz
-f933ec308277523aa5d7b8f679651af207de969daa3fc0eff152db394a08dd18647e994e6b03e053e862736c8a756adea5e82b242fe6182f2288395e05c40de8 CVE-2020-12672.patch"
+sha512sums="27ed5fcbfb0303436bdcb0f11d18257a967d471251b51e633e2c655b0a7e5ed01f61a61f9702cc7d4c02714e005ac18ca9ba0f690c0580e41d07947a03c5cbb4 GraphicsMagick-1.3.36.tar.xz"
diff --git a/community/graphicsmagick/CVE-2020-12672.patch b/community/graphicsmagick/CVE-2020-12672.patch
deleted file mode 100644
index 9e29052cafc..00000000000
--- a/community/graphicsmagick/CVE-2020-12672.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-diff -r 4917a4242fc0 -r 50395430a371 coders/png.c
---- a/coders/png.c Fri May 01 13:49:13 2020 -0500
-+++ b/coders/png.c Sat May 30 10:18:16 2020 -0500
-@@ -5689,7 +5691,28 @@
-
- if (logging)
- (void) LogMagickEvent(CoderEvent,GetMagickModule(),
-- " Processing MNG MAGN chunk");
-+ " Processing MNG MAGN chunk: MB=%u, ML=%u,"
-+ " MR=%u, MT=%u, MX=%u, MY=%u,"
-+ " X_method=%u, Y_method=%u",
-+ mng_info->magn_mb,mng_info->magn_ml,
-+ mng_info->magn_mr,mng_info->magn_mt,
-+ mng_info->magn_mx,mng_info->magn_my,
-+ mng_info->magn_methx,
-+ mng_info->magn_methy);
-+
-+ /*
-+ If the image width is 1, then X magnification is done
-+ by simple pixel replication.
-+ */
-+ if (image->columns == 1)
-+ mng_info->magn_methx = 1;
-+
-+ /*
-+ If the image height is 1, then Y magnification is done
-+ by simple pixel replication.
-+ */
-+ if (image->rows == 1)
-+ mng_info->magn_methy = 1;
-
- if (mng_info->magn_methx == 1)
- {
-@@ -5734,12 +5757,10 @@
- Image
- *large_image;
-
-- int
-- yy;
--
- long
- m,
-- y;
-+ y,
-+ yy;
-
- register long
- x;
-