aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-31 23:39:55 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-12 17:23:54 -0300
commit1be32457092bfa8bf744de891c9a7fb938031074 (patch)
tree653c4d868e14835c8d767e79e2a4b0903fa4f620
parentbdcff9d4e80ef8dc5a9d920397f74dd1352424fe (diff)
community/py3-qt5: build QtWebChannel bindings
Required for py3-qtwebengine
-rw-r--r--community/py3-qt5/APKBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/community/py3-qt5/APKBUILD b/community/py3-qt5/APKBUILD
index e37b7032bdf..8a7ad47471e 100644
--- a/community/py3-qt5/APKBUILD
+++ b/community/py3-qt5/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-qt5
_pkgname=PyQt5
pkgver=5.12.2
-pkgrel=0
+pkgrel=1
pkgdesc="A set of Python 3 bindings for the Qt toolkit"
url="http://riverbankcomputing.co.uk/software/pyqt/intro"
arch="all"
@@ -13,18 +13,17 @@ makedepends="python3-dev py-dbus-dev py-sip-dev
qt5-qtbase-dev libx11-dev qt5-qtsvg-dev qt5-qtwebsockets-dev
py-opengl qt5-qtconnectivity-dev qt5-qtmultimedia-dev qt5-qttools-dev
qt5-qtserialport-dev qt5-qtx11extras-dev qt5-qtdeclarative-dev
+ qt5-qtwebchannel-dev
"
source="https://www.riverbankcomputing.com/static/Downloads/PyQt5/$pkgver/PyQt5_gpl-$pkgver.tar.gz"
builddir="${srcdir}/${_pkgname}_gpl-${pkgver}"
prepare() {
default_prepare
- cd "$builddir"
sed -i '/target_config.dbus_inc_dirs = \[\]/d' configure.py
}
build() {
- cd "$builddir"
python3 configure.py \
--confirm-license \
--qmake /usr/lib/qt5/bin/qmake \
@@ -36,12 +35,10 @@ build() {
}
check() {
- cd "$builddir"
- make check
+ make check
}
-package(){
- cd "$builddir"
+package() {
make -j1 DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
}