aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2020-04-09 12:11:22 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-04-09 15:11:24 +0000
commit1c7ba057cebc74c8b4db0a2c40c1b2c508e8c484 (patch)
tree710320297d2328f018ecd88914db69750ce631b7
parent54cdc723c10d40c21c18545e4949089155617074 (diff)
main/zsh: don't attempt to add ~/bin to PATH by default
Does not work correctly as /etc/profile (sourced by zprofile) overwrites PATH again. Besides, I believe that locations such as ~/bin should be explicitly enabled by the user. Other shells (e.g. bash, mksh, …) do not add ~/bin to PATH by default either. Fixes #11371
-rw-r--r--main/zsh/APKBUILD4
-rw-r--r--main/zsh/zprofile3
2 files changed, 2 insertions, 5 deletions
diff --git a/main/zsh/APKBUILD b/main/zsh/APKBUILD
index 258db227943..9986a1ced0e 100644
--- a/main/zsh/APKBUILD
+++ b/main/zsh/APKBUILD
@@ -11,7 +11,7 @@
#
pkgname=zsh
pkgver=5.8
-pkgrel=0
+pkgrel=1
pkgdesc="Very advanced and programmable command interpreter (shell)"
url="https://www.zsh.org/"
arch="all"
@@ -166,4 +166,4 @@ _submv() {
}
sha512sums="96198ecef498b7d7945fecebbe6bf14065fa8c5d81a7662164579eba8206b79575812d292adea1864bc7487ac0818ba900e25f9ab3802449340de80417c2c533 zsh-5.8.tar.xz
-59182b99447872ded8adf0d890e9359ee47fce0b7acb2808f4308f945885fbf6d977a0917bbb5c0f21454caf3ba06ab092127732da4f84292d6ab0989a0110fe zprofile"
+1067ad916d8921fe8880e040453782dcaafb6c05566f72b806e71aef2c2a53f25b6039cf8133196dd52cf7e23b172452ef3f77188bab8c8b1a50c1ea6ffa176a zprofile"
diff --git a/main/zsh/zprofile b/main/zsh/zprofile
index 03d316f1add..5e214759d95 100644
--- a/main/zsh/zprofile
+++ b/main/zsh/zprofile
@@ -2,9 +2,6 @@
# /etc/zprofile and ~/.zprofile are run for login shells
#
-PATH="$PATH:$HOME/bin"
-export PATH
-
_src_etc_profile()
{
# Make /etc/profile happier, and have possible ~/.zshenv options like