aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2021-04-19 08:27:19 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2021-04-19 09:05:03 +0000
commit1cdcca231135275ae057e9af004e22e9b0657f41 (patch)
tree9509474d80cb28ac904d54b526c46d1185b1d18a
parentd02561956e5c12f1df59d646c757b8669ac52398 (diff)
testing/snapper: fix build on 32 bit arches
Fixes #12617
-rw-r--r--testing/snapper/APKBUILD10
-rw-r--r--testing/snapper/fix-32bit-build.patch36
2 files changed, 42 insertions, 4 deletions
diff --git a/testing/snapper/APKBUILD b/testing/snapper/APKBUILD
index e8ac684322f..5125247209e 100644
--- a/testing/snapper/APKBUILD
+++ b/testing/snapper/APKBUILD
@@ -2,10 +2,10 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=snapper
pkgver=0.9.0
-pkgrel=1
+pkgrel=2
pkgdesc="Manage filesystem snapshots and allow undo of system modifications"
url="http://snapper.io"
-arch="all !x86 !armhf !armv7" # Fails to build on 32bit arches, see #12617
+arch="all !armhf !armv7" # Fails to build on 32bit arches, see #12617
license="GPL-2.0-or-later"
options="!check" # 5 tests failing - https://github.com/openSUSE/snapper/issues/526
depends="dbus"
@@ -18,7 +18,8 @@ subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="$pkgname-$pkgver.tar.gz::https://github.com/openSUSE/snapper/archive/v$pkgver.tar.gz
musl-stdout_stderr.patch
musl-_nl_msg_cat_cntr.patch
- miss-tinfo-link-to-ncurses.patch"
+ miss-tinfo-link-to-ncurses.patch
+ fix-32bit-build.patch"
prepare() {
default_prepare
@@ -67,4 +68,5 @@ package() {
sha512sums="0861621764b65365ea7e7cf48baa0c7a64351fed7fca439c91ebf8023dbad6d05c709a5c49b3755d1edbd1b98617b8c202239a63608c11aee808ac21d6a2b412 snapper-0.9.0.tar.gz
5baf722996706146b62fd0a0d9b321496fb122e700af2d3dfd8272de2678f29c79bc2b1a03634b04aab3f226632dfdebc5674d3128737e85bcc71461e951d95b musl-stdout_stderr.patch
6f3324700cc697b29b2fe14e42eb765b4474bf7e582d8ea53122fe66e128d17584489c8e2adbfecc8aac37c683a9d4dc2a821e3ea0143334cd8b899164ba708c musl-_nl_msg_cat_cntr.patch
-3d264f7f9156342d5bad2ac78db9c8a30ea1ac25648245631a47d1495bb6610c6b39c28a5013741063df3c08f459388c0467caaedde5ad7cebb433eb432b7a70 miss-tinfo-link-to-ncurses.patch"
+3d264f7f9156342d5bad2ac78db9c8a30ea1ac25648245631a47d1495bb6610c6b39c28a5013741063df3c08f459388c0467caaedde5ad7cebb433eb432b7a70 miss-tinfo-link-to-ncurses.patch
+20cd4e518f840099d097c765d10c5b8f22d629a9e48bace53712e2ec7fc34c782fdf2b237451ebd32f1db6c6722027f661f92cc021617e70ce2d1987146c57f6 fix-32bit-build.patch"
diff --git a/testing/snapper/fix-32bit-build.patch b/testing/snapper/fix-32bit-build.patch
new file mode 100644
index 00000000000..042e0b11644
--- /dev/null
+++ b/testing/snapper/fix-32bit-build.patch
@@ -0,0 +1,36 @@
+From 52529494c827e7d4045a5ee368331b67c0be5364 Mon Sep 17 00:00:00 2001
+From: Arvin Schnell <aschnell@suse.de>
+Date: Mon, 19 Apr 2021 09:57:59 +0200
+Subject: [PATCH] - fix build on 32 bit musl systems
+
+---
+ client/cleanup.cc | 2 +-
+ package/snapper.changes | 5 +++++
+ 2 files changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/client/cleanup.cc b/client/cleanup.cc
+index 801c0f55..e57a0a80 100644
+--- a/client/cleanup.cc
++++ b/client/cleanup.cc
+@@ -51,7 +51,7 @@ struct Parameters
+ MinFreeLimit free_limit;
+
+
+- void read(const ProxyConfig& config, const char* name, long int& value)
++ void read(const ProxyConfig& config, const char* name, time_t& value)
+ {
+ const map<string, string>& raw = config.getAllValues();
+ map<string, string>::const_iterator pos = raw.find(name);
+diff --git a/package/snapper.changes b/package/snapper.changes
+index 0f61ba77..684eafd0 100644
+--- a/package/snapper.changes
++++ b/package/snapper.changes
+@@ -1,3 +1,8 @@
++-------------------------------------------------------------------
++Mon Apr 19 09:56:40 CEST 2021 - aschnell@suse.com
++
++- fix build on 32 bit musl systems (gh#openSUSE/snapper#644)
++
+ -------------------------------------------------------------------
+ Fri Apr 09 15:23:14 CEST 2021 - aschnell@suse.com
+