aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Demelier <markand@malikania.fr>2020-04-06 10:43:50 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-04-06 22:37:01 +0000
commit1dc64ac8d03063f3e6423cdfcf6d16050a72f412 (patch)
tree818fd8fb216dc3ff5b7ffbe797be9180714f396f
parent99f2e56141eab524b73b0e8e6b1d5c42508041eb (diff)
testing/libretro-fuse: new aport
https://github.com/libretro/fuse-libretro port of the Fuse Unix Spectrum Emulator to libretro
-rw-r--r--testing/libretro-fuse/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/libretro-fuse/APKBUILD b/testing/libretro-fuse/APKBUILD
new file mode 100644
index 00000000000..76d628e7f5c
--- /dev/null
+++ b/testing/libretro-fuse/APKBUILD
@@ -0,0 +1,23 @@
+# Contributor: David Demelier <markand@malikania.fr>
+# Maintainer: David Demelier <markand@malikania.fr>
+pkgname=libretro-fuse
+pkgver=0_git20200207
+pkgrel=0
+_commit="ef603d165914afc3f54971d082e69adea187c8ec"
+pkgdesc="port of the Fuse Unix Spectrum Emulator to libretro"
+url="https://github.com/libretro/fuse-libretro"
+arch="all"
+license="GPL-3.0-only"
+source="$pkgname-$_commit.tar.gz::https://github.com/libretro/fuse-libretro/archive/$_commit.tar.gz"
+builddir="$srcdir/fuse-libretro-$_commit"
+options="!check" # No tests
+
+build() {
+ make -f Makefile.libretro
+}
+
+package() {
+ install -Dm644 fuse_libretro.so "$pkgdir"/usr/lib/libretro/fuse_libretro.so
+}
+
+sha512sums="b1a14a9cc1ece9ad6d2acce5f2a6ec4aca7201d09c27da5493829a78c2e07166355bd9f438984e4ebf9b09670faa1ad0638752834b8233a335e3cb5b3b5174e1 libretro-fuse-ef603d165914afc3f54971d082e69adea187c8ec.tar.gz"