aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Berthault <justin.berthault@zaclys.net>2020-06-01 12:15:25 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-06-01 15:57:29 +0000
commit1eb7649a6ff0a091f76469d14c165731d8d518e0 (patch)
tree29c7141ae805e4fa0014b6140a2af78bdf6510c3
parentbf12022268751a6eec4883df2c7347f5bc734923 (diff)
testing/vimb: new aport
https://fanglingsu.github.io/vimb/ The vim like browser
-rw-r--r--testing/vimb/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/vimb/APKBUILD b/testing/vimb/APKBUILD
new file mode 100644
index 00000000000..40f9d7efa5d
--- /dev/null
+++ b/testing/vimb/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Justin Berthault <justin.berthault@zaclys.net>
+# Maintainer: Justin Berthault <justin.berthault@zaclys.net>
+pkgname=vimb
+pkgver=3.6.0
+pkgrel=0
+pkgdesc="The vim like browser"
+url="https://fanglingsu.github.io/vimb/"
+arch="all"
+license="GPL-3.0-or-later"
+makedepends="webkit2gtk-dev"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/fanglingsu/vimb/archive/$pkgver.tar.gz"
+
+build() {
+ make PREFIX=/usr
+}
+
+check() {
+ make test
+}
+
+package() {
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}
+
+sha512sums="0c1a131641c47ec0dd7a5346d5e7260f85293ecc105e04e6265680c53bbbdc8d98acc4f4e11443efc4e4148aa0b77c496cf7e5f59d44857e6e612c3d4a643c8f vimb-3.6.0.tar.gz"