aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMilan P. Stanić <mps@arvanta.net>2021-01-18 09:04:36 +0000
committerLeo <thinkabit.ukim@gmail.com>2021-01-18 11:43:22 +0000
commit1f69236b64bb0c5bd19989d2a39e7612e0ef0872 (patch)
tree9b85f50dccda25258c0aea6cc32a3279de0ebdd4
parentc2868dae68126ff7aeb643e4720b2f0a80258312 (diff)
main/postfix: upgrade to 3.5.9
remove postfix-musl-2.patch, applied upstream
-rw-r--r--main/postfix/APKBUILD6
-rw-r--r--main/postfix/postfix-musl-2.patch53
2 files changed, 2 insertions, 57 deletions
diff --git a/main/postfix/APKBUILD b/main/postfix/APKBUILD
index e6ff3d9c710..56330592fdd 100644
--- a/main/postfix/APKBUILD
+++ b/main/postfix/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Łukasz Jendrysik <scadu@yandex.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=postfix
-pkgver=3.5.8
+pkgver=3.5.9
pkgrel=0
pkgdesc="Secure and fast drop-in replacement for Sendmail (MTA)"
url="http://www.postfix.org/"
@@ -41,7 +41,6 @@ pkgusers="postfix"
pkggroups="postfix postdrop"
source="https://de.postfix.org/ftpmirror/official/postfix-$pkgver.tar.gz
$pkgname.initd
- postfix-musl-2.patch
postfix-install.patch
lmdb-default.patch
"
@@ -197,8 +196,7 @@ stone() {
find src/smtpstone -mindepth 1 -perm 0755 -exec cp {} "$subpkgdir"/usr/bin \;
}
-sha512sums="0abb07d99e343b76e6a26b4a090af9d592f4dfd03c8c737cc72bfb0f4267dafcbb0cb0aa7b6255f8b834c9289d89a5c47b167be3758239309937cb77e0d9464b postfix-3.5.8.tar.gz
+sha512sums="9ff3a33cdd5811e470d5c6cfa896fa76e4d3257b139deec5f420d18e34232f327b7c8496c5d13566c6f9ae1fdf8719feb9981372b2869b0208a2eb3a1daaeadd postfix-3.5.9.tar.gz
2752e69c4e1857bdcf29444ffb458bca818bc60b9c77c20823c5f5b87c36cb5e0f3217a625a7fe5788d5bfcef7570a1f2149e1233fcd23ccf7ee14190aff47a2 postfix.initd
-7b9d658a6130295b0e0bcf19db064d9daf21a783ef865d83d62eb09176380b7ee5e6a73f6c5ad82f3c1eded1f0c351ed55b203dfffe32c0071e5bb2b16edfeb5 postfix-musl-2.patch
25cd34f23ca909d4e33aaf3239d1e397260abc7796d9a4456dee4f005682fd3a58aab8106126e5218c95bdddae415a3ef7e2223cd3b0d7b1e2bd76158bb7eaf8 postfix-install.patch
0769e2e503486f8dd6fa21f2c534ad7df7a9f1bb57dde2f0ad61863a3e615d0a6dc18132b27796eb28cd81afb2b4e97c65c9d490a391f835aa3b7b18e74252c5 lmdb-default.patch"
diff --git a/main/postfix/postfix-musl-2.patch b/main/postfix/postfix-musl-2.patch
deleted file mode 100644
index 6ddd0376342..00000000000
--- a/main/postfix/postfix-musl-2.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-diff --git a/postfix/makedefs b/postfix/makedefs
-index 64b42f44..aea15d6f 100644
---- a/makedefs
-+++ b/makedefs
-@@ -228,19 +228,6 @@ case $# in
- *) echo usage: $0 [system release] 1>&2; exit 1;;
- esac
-
--case "$SYSTEM" in
-- Linux)
-- case "`PATH=/bin:/usr/bin ldd /bin/sh`" in
-- *-musl-*)
-- case "$CCARGS" in
-- *-DNO_DNSSEC*) ;;
-- *) echo Warning: libc-musl breaks DANE/TLSA security. 1>&2
-- echo This build will not support DANE/TLSA. 1>&2
-- CCARGS="$CCARGS -DNO_DNSSEC";;
-- esac;;
-- esac;;
--esac
--
- case "$SYSTEM.$RELEASE" in
- SCO_SV.3.2) SYSTYPE=SCO5
- # Use the native compiler by default
-diff --git a/postfix/src/dns/dns_lookup.c b/postfix/src/dns/dns_lookup.c
-index 11c92813..b3bd537a 100644
---- a/src/dns/dns_lookup.c
-+++ b/src/dns/dns_lookup.c
-@@ -350,7 +350,9 @@ static int dns_res_query(const char *name, int class, int type,
- if (msg_verbose)
- msg_info("res_mkquery() failed");
- return (len);
-- } else if ((len = res_send(msg_buf, len, answer, anslen)) < 0) {
-+ }
-+ msg_buf[3] |= 32; // AD flag
-+ if ((len = res_send(msg_buf, len, answer, anslen)) < 0) {
- SET_H_ERRNO(TRY_AGAIN);
- if (msg_verbose)
- msg_info("res_send() failed");
-@@ -491,11 +493,12 @@ static int dns_query(const char *name, int type, unsigned flags,
- for (;;) {
- _res.options &= ~saved_options;
- _res.options |= flags;
-- if (keep_notfound && var_dns_ncache_ttl_fix) {
-+ if (1) {
- #ifdef HAVE_RES_SEND
- len = dns_res_query((char *) name, C_IN, type, reply->buf,
- reply->buf_len);
- #else
-+#error HAVE_RES_SEND not defined
- var_dns_ncache_ttl_fix = 0;
- msg_warn("system library does not support %s=yes"
- " -- ignoring this setting", VAR_DNS_NCACHE_TTL_FIX);