aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-29 14:34:36 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-29 14:34:36 -0300
commit22e8ce51842ed8b49b536d6e04a705552e87ad1d (patch)
tree59925a95970dfdd32ea108fa5871266972820990
parent6a36a973c6a2edebe3f9868af9cccb3eb695088e (diff)
testing/mgba: disable on arches that do not have qt5-qtmultimedia
-rw-r--r--testing/mgba/APKBUILD4
1 files changed, 1 insertions, 3 deletions
diff --git a/testing/mgba/APKBUILD b/testing/mgba/APKBUILD
index 70dd8cd41e1..e8b377f4238 100644
--- a/testing/mgba/APKBUILD
+++ b/testing/mgba/APKBUILD
@@ -6,6 +6,7 @@ pkgrel=3
pkgdesc="Game Boy Advance Emulator"
url="https://github.com/mgba-emu/mgba"
arch="all !s390x !mips !mips64" # broken on big-endian
+arch="$arch !armhf !armv7" # Missing qt5-qtmultimedia-dev
license="MPL-2.0"
makedepends="cmake qt5-qtmultimedia-dev qt5-qtbase-dev qt5-qttools-dev
sdl-dev libzip-dev zlib-dev libpng-dev ffmpeg-dev imagemagick-dev
@@ -19,11 +20,8 @@ source="mgba-$pkgver.tar.gz::https://github.com/mgba-emu/mgba/archive/$pkgver.ta
python3.patch
mgba-qt5.11.patch
mgba-qt.desktop"
-builddir="$srcdir/mgba-$pkgver"
build() {
- cd "$builddir"
-
# declaration mismatch in include/mgba/core/thread.h
export CPPFLAGS="$CPPFLAGS -fno-strict-aliasing"