aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2020-05-14 09:42:01 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2020-05-14 12:58:07 +0000
commit230d63953206b41020a702d2c4b9db4046d2b5bc (patch)
treee92cc90b523e90c15c316c1bc2802b2865fb282e
parentd08ae39dfc5bbb5bf3c7dfd6e47b11dc460b4d50 (diff)
community/gvm-libs: upgrade to 11.0.1
-rw-r--r--community/gvm-libs/APKBUILD13
-rw-r--r--community/gvm-libs/fix-sigsegv-no-plugin_feed_info.inc-file-present.patch13
-rw-r--r--community/gvm-libs/support-gnutls-missing.patch10
3 files changed, 5 insertions, 31 deletions
diff --git a/community/gvm-libs/APKBUILD b/community/gvm-libs/APKBUILD
index e389822d903..ca8c9234e87 100644
--- a/community/gvm-libs/APKBUILD
+++ b/community/gvm-libs/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=gvm-libs
-pkgver=11.0.0
-pkgrel=4
+pkgver=11.0.1
+pkgrel=0
pkgdesc="Greenbone Vulnerability Management Libraries"
url="https://www.openvas.org/"
arch="all"
@@ -16,12 +16,11 @@ makedepends="cmake bison glib-dev libpcap-dev libssh-dev
libgcrypt-dev libksba-dev openldap-dev
gpgme-dev gpgmepp net-snmp-libs e2fsprogs-dev
clang-dev freeradius-client-dev
- doxygen libxslt graphviz xmltoman perl-sql-translator"
+ doxygen libxslt graphviz xmltoman perl-sql-translator
+ libxml2-dev"
subpackages="$pkgname-dev $pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/greenbone/gvm-libs/archive/v$pkgver.tar.gz
malloc-trim.patch
- support-gnutls-missing.patch
- fix-sigsegv-no-plugin_feed_info.inc-file-present.patch
glib-include-path.patch
strptime.patch"
@@ -64,9 +63,7 @@ doc() {
mv doc/generated/* "$subpkgdir"/usr/share/doc/$pkgname
}
-sha512sums="ff981b4ca37b425a8d1f491e90bd1cef4701033886f9fd47dad34540b36fa275d4af8b176e63a07405cc1f29137851b96a6ce80c46ed92f809b089fb0cd928af gvm-libs-11.0.0.tar.gz
+sha512sums="159acbe8e24f172398a6396988b87676a214fa15c2985e67845dcad1ebcb92ba5e2a19cee2994dc7cd0cac706992e81e8c6a793e99216aaac87a91c1c72c9a46 gvm-libs-11.0.1.tar.gz
ae93ac7ec929325926d785bb58ed9c09f8bdaf518adf09db54bb9a8a4b5e4474c0ab61fc987c91114f2013cbe39868115006b528865fbd027e5b88eca58f1954 malloc-trim.patch
-dcb83b3ec8a4d21b6097c0eb67e28b3e9abb128b691d143788713fbffd704c132e4fa552fb9fc773e32888a8d5006d56647f28ff7d0b8833e1911a3a94acc4a4 support-gnutls-missing.patch
-4da0ad259926bba976ed634501500bb8a38ac3f2ff873aad1a3de8a86ae29032ec22cb8a494d3144945f6fab49031e228f4262032b007b41b3a123893b86be93 fix-sigsegv-no-plugin_feed_info.inc-file-present.patch
c0fe0add24cb4336f0ce313197042e60a3aba3eeb983f31b243e665a488e520ffa260ab9a3feb852500310a9df66f2eaf82ac4294d7980b983a78454b30eb9f9 glib-include-path.patch
b10f2b6a8e126a184c65c91bdd18a21e4ee16cbc442775288a11c2768c8e5c1db4ce3749025e7cc3f360c7c1011b79dca836fee742fb9f06034ca0a986f718b5 strptime.patch"
diff --git a/community/gvm-libs/fix-sigsegv-no-plugin_feed_info.inc-file-present.patch b/community/gvm-libs/fix-sigsegv-no-plugin_feed_info.inc-file-present.patch
deleted file mode 100644
index e343c2c079f..00000000000
--- a/community/gvm-libs/fix-sigsegv-no-plugin_feed_info.inc-file-present.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/util/nvticache.c b/util/nvticache.c
-index 162e5851..9a2b7287 100644
---- a/util/nvticache.c
-+++ b/util/nvticache.c
-@@ -189,7 +189,7 @@ nvticache_save ()
- }
- old_version = nvticache_feed_version ();
- feed_version = nvt_feed_version ();
-- if (g_strcmp0 (old_version, feed_version))
-+ if (feed_version && g_strcmp0 (old_version, feed_version))
- {
- kb_item_set_str (cache_kb, NVTICACHE_STR, feed_version, 0);
- g_message ("Updated NVT cache from version %s to %s", old_version,
diff --git a/community/gvm-libs/support-gnutls-missing.patch b/community/gvm-libs/support-gnutls-missing.patch
deleted file mode 100644
index 853e3b6bd8f..00000000000
--- a/community/gvm-libs/support-gnutls-missing.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/util/CMakeLists.txt.orig 2019-10-13 22:39:53.333743843 +0800
-+++ b/util/CMakeLists.txt 2019-10-13 22:40:08.804743702 +0800
-@@ -159,6 +159,7 @@
- target_link_libraries (gvm_util_shared LINK_PRIVATE ${GLIB_LDFLAGS}
- ${GIO_LDFLAGS} ${GPGME_LDFLAGS} ${ZLIB_LDFLAGS}
- ${RADIUS_LDFLAGS} ${LIBSSH_LDFLAGS}
-+ ${GNUTLS_LDFLAGS}
- ${GCRYPT_LDFLAGS} ${LDAP_LDFLAGS} ${REDIS_LDFLAGS}
- ${UUID_LDFLAGS} ${LINKER_HARDENING_FLAGS})
- endif (BUILD_SHARED)