aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-05-22 19:34:50 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-05-23 08:54:38 +0000
commit2456b5ab1209b466aedd8c5083b6d883a77af8dc (patch)
tree67eeeb9ab6906e1f398ff2ead34f98cbfa1489b5
parent0c24fd09869f45aa668d5761f6602ed4a2fc463b (diff)
testing/ausweisapp2: modernize
Use None instead of Release
-rw-r--r--testing/ausweisapp2/APKBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/testing/ausweisapp2/APKBUILD b/testing/ausweisapp2/APKBUILD
index db648a5c6ad..9417873480d 100644
--- a/testing/ausweisapp2/APKBUILD
+++ b/testing/ausweisapp2/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=ausweisapp2
pkgver=1.20.0
-pkgrel=0
+pkgrel=1
pkgdesc="Official authentication app for German ID card and residence permit"
url="https://www.ausweisapp.bund.de/"
arch="all"
@@ -16,14 +16,18 @@ options="!check" # no upstream tests in release build
builddir="$srcdir/AusweisApp2-$pkgver"
build() {
- mkdir -p build && cd build
- cmake -DCMAKE_BUILD_TYPE=release -DCMAKE_INSTALL_PREFIX=/usr ..
- make
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake -B build \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ $CMAKE_CROSSOPTS .
+ make -C build
}
package() {
- cd build
- make DESTDIR="$pkgdir" install
+ make -C build DESTDIR="$pkgdir" install
}
sha512sums="9fe83d59a02e8ae89dae9264a94b3d1bd943b6d4843dd8a833e9bb65a0d98c6d78f7c7b69f5cae74f013b84bf580228e1a9805f8deb8fcfc33f002f73e61d4ee AusweisApp2-1.20.0.tar.gz"