aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-09-09 05:16:26 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-09-09 05:18:26 -0300
commit24e960791e3e6c28efc0a4b7204e679a7d5e08a3 (patch)
tree1fb1993a8f70befd26f390f2c8c49f330c992782
parent0d7d68b58e596b80be44e227152bb02024db18ba (diff)
main/libxdamage: disable static
-rw-r--r--main/libxdamage/APKBUILD8
1 files changed, 3 insertions, 5 deletions
diff --git a/main/libxdamage/APKBUILD b/main/libxdamage/APKBUILD
index 0e035451200..6ed10e947c5 100644
--- a/main/libxdamage/APKBUILD
+++ b/main/libxdamage/APKBUILD
@@ -1,13 +1,12 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libxdamage
pkgver=1.1.5
-pkgrel=0
+pkgrel=1
pkgdesc="X11 damaged region extension library"
url="http://xorg.freedesktop.org/"
arch="all"
license="MIT"
options="!check" # No test suite.
-depends=
makedepends="xorgproto libx11-dev libxfixes-dev util-macros"
subpackages="$pkgname-dev"
source="https://www.x.org/releases/individual/lib/libXdamage-$pkgver.tar.bz2"
@@ -15,17 +14,16 @@ source="https://www.x.org/releases/individual/lib/libXdamage-$pkgver.tar.bz2"
builddir="$srcdir"/libXdamage-$pkgver
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
- --sysconfdir=/etc
+ --sysconfdir=/etc \
+ --disable-static
make
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}