aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-08-15 04:31:12 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-08-15 04:31:12 -0300
commit2639e57cd0d7157c13ff0a967c9ef4d247e47198 (patch)
tree420a1abb0359fcdc0e06eeef9f13783fb03abefa
parentfd67c24147c269b86e28192d244965e6c402aeb4 (diff)
main/gzip: depend on less
fixes #8097
-rw-r--r--main/gzip/APKBUILD15
1 files changed, 4 insertions, 11 deletions
diff --git a/main/gzip/APKBUILD b/main/gzip/APKBUILD
index 2ea52d44caf..bdb30df8d5f 100644
--- a/main/gzip/APKBUILD
+++ b/main/gzip/APKBUILD
@@ -2,21 +2,16 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gzip
pkgver=1.10
-pkgrel=0
-pkgdesc="A popular data compression program"
+pkgrel=1
+pkgdesc="Popular data compression program"
subpackages="$pkgname-doc"
url="https://www.gnu.org/software/gzip/"
arch="all"
-license="GPL-2.0"
-depends=
-makedepends=
-checkdepends="less"
-install=
+license="GPL-3.0-or-later"
+depends="less"
source="https://ftp.gnu.org/gnu/gzip/gzip-$pkgver.tar.gz"
build() {
- cd "$builddir"
-
# avoid text relocation
export DEFS="NO_ASM"
./configure \
@@ -29,12 +24,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR=$pkgdir install
rm -rf "$pkgdir"/usr/lib/charset.alias