aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Liske <thomas@fiasko-nw.net>2020-08-08 14:21:09 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-08-11 04:43:19 +0000
commit26c15e1eb8f0128a46b5f302bdb90ff9d762618b (patch)
tree84580d99aec85d71d624e09fd2392b8cbe57e938
parent71a4ed305eb210f124bd342fe4c5929f304fe14c (diff)
community/postsrsd: use checkpath in initd to create non-public files
-rw-r--r--community/postsrsd/APKBUILD4
-rw-r--r--community/postsrsd/postsrsd.initd3
2 files changed, 3 insertions, 4 deletions
diff --git a/community/postsrsd/APKBUILD b/community/postsrsd/APKBUILD
index cee191ad6ea..1acdbe91a1c 100644
--- a/community/postsrsd/APKBUILD
+++ b/community/postsrsd/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=postsrsd
pkgver=1.6
-pkgrel=2
+pkgrel=3
pkgdesc="Postfix Sender Rewriting Scheme daemon"
url="https://github.com/roehling/postsrsd"
arch="all"
@@ -47,4 +47,4 @@ package() {
sha512sums="b2df4cdec41361e15cd8c9207fb16564d607559bcb36dd73c9347b90e4f3c2414b88434ef1ffe6a18783f38c5960383516e40e4ffa28802a03539e52ca723aa1 postsrsd-1.6.tar.gz
96a1c4e04ded844b98e5b5e263af51389ad8f1424a0fcd923f8156a2f9491b67552fbe3b5ad972cf1279d7b0e022787d151b5151a27da43227176356848ec4d7 10-fix-defaults.patch
-bec690156e60a10286f92470420e2caccd0cd8fd5707fefddeb768b36a4697b9651acd707c7de08a99832a8b27a0328560501fb1376fe39bc27f5fbe4dca7797 postsrsd.initd"
+8541fbd517370cabf905b992ba4aeccc249c56b71bf0c3f5f50c13a4bbc9e191265632147d9f2cd617911049144abbf0f2c510d0fa41ba4268ccf1ede9798116 postsrsd.initd"
diff --git a/community/postsrsd/postsrsd.initd b/community/postsrsd/postsrsd.initd
index 4256c3942dd..7abaa640843 100644
--- a/community/postsrsd/postsrsd.initd
+++ b/community/postsrsd/postsrsd.initd
@@ -25,11 +25,10 @@ start_pre() {
if [ ! -s /etc/postsrsd/postsrsd.secret ]
then
ebegin "Generating secret"
+ checkpath -Fm 0600 -o postsrsd ${SRS_SECRET}
dd if=/dev/urandom bs=18 count=1 status=none \
| base64 >${SRS_SECRET}
- chmod 0600 ${SRS_SECRET}
- chown postsrsd ${SRS_SECRET}
eend $?
fi
}