aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2021-01-08 10:10:21 -0300
committerLeo <thinkabit.ukim@gmail.com>2021-01-08 14:16:08 +0000
commit299ee1bf40925ba212d3fe03e84c9e38d47a85ed (patch)
tree1ac529323e0ce39e9dd5e2578fef75d5188066d9
parentd845644e1a040cee3a7f7835b4547b97b90b6136 (diff)
main/dpkg: upgrade to 1.20.6
-rw-r--r--main/dpkg/APKBUILD11
-rw-r--r--main/dpkg/time_t.patch95
2 files changed, 5 insertions, 101 deletions
diff --git a/main/dpkg/APKBUILD b/main/dpkg/APKBUILD
index 34c88c541e4..ba46b2b165d 100644
--- a/main/dpkg/APKBUILD
+++ b/main/dpkg/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=dpkg
-pkgver=1.20.5
-pkgrel=3
+pkgver=1.20.6
+pkgrel=0
pkgdesc="The Debian Package Manager"
url="https://wiki.debian.org/Teams/Dpkg"
arch="all"
@@ -12,7 +12,7 @@ makedepends="bzip2-dev linux-headers perl zlib-dev po4a"
subpackages="$pkgname-doc $pkgname-dev"
source="https://deb.debian.org/debian/pool/main/d/dpkg/dpkg_$pkgver.tar.xz
0001-t-command-Fix-test_command_exec-program-invocation.patch
- time_t.patch"
+ "
prepare() {
default_prepare
@@ -91,6 +91,5 @@ dev() {
mv "$pkgdir"/usr/share/perl* "$subpkgdir"/usr/share/
}
-sha512sums="6b3789c25c81022181b87a28ca9baa4a463a68940a871568c699a2a30e3b4ce705835ed6a171ac8c5902e377200b31cc0be1e03cbd7d35c4eaf92c7300d9227f dpkg_1.20.5.tar.xz
-059875c06146382f1e4a339860c558a71393a43bf9e6580c0a2211c629cc9be1b4fd12c900b002f833a241ad9a339f138b458b60664da06db5b32db1c6490b2f 0001-t-command-Fix-test_command_exec-program-invocation.patch
-4eb01daac6d1079bcac1450b52c0d052de2c2f0341feafb4b5e2b23b7c191c9ce21d2e8e3b9ea917f8f81162229c4575bbf62f1d1f38da21b7dfd1fe80569bce time_t.patch"
+sha512sums="1aee5091cfa1f5221e64785ff013c6323f7a8bcc0d0b82caa5357db7fe480412a73f6afbd850ab1c53397dd0b2bca1b2637111d1cb3bdbfafe9df185955b7e2d dpkg_1.20.6.tar.xz
+059875c06146382f1e4a339860c558a71393a43bf9e6580c0a2211c629cc9be1b4fd12c900b002f833a241ad9a339f138b458b60664da06db5b32db1c6490b2f 0001-t-command-Fix-test_command_exec-program-invocation.patch"
diff --git a/main/dpkg/time_t.patch b/main/dpkg/time_t.patch
deleted file mode 100644
index a47675654ec..00000000000
--- a/main/dpkg/time_t.patch
+++ /dev/null
@@ -1,95 +0,0 @@
-musl 1.2 switched from 32-bit time_t to 64-bit time_t on 32-bit arches.
-Unfourtunatly, the dpkg code assumes that time_t is a long int (or long
-unsigned int in some place). As a dirty workaround use PRId64 instead.
-
-See also: http://musl.libc.org/time64.html
-
-diff -upr dpkg-1.20.5.orig/dpkg-deb/build.c dpkg-1.20.5/dpkg-deb/build.c
---- dpkg-1.20.5.orig/dpkg-deb/build.c 2020-06-27 20:24:28.000000000 +0200
-+++ dpkg-1.20.5/dpkg-deb/build.c 2020-08-27 23:00:05.501645000 +0200
-@@ -38,6 +38,7 @@
- #include <stdint.h>
- #include <stdlib.h>
- #include <stdio.h>
-+#include <inttypes.h>
-
- #include <dpkg/i18n.h>
- #include <dpkg/c-ctype.h>
-@@ -457,7 +458,7 @@ tarball_pack(const char *dir, filenames_
- if (chdir(dir))
- ohshite(_("failed to chdir to '%.255s'"), dir);
-
-- snprintf(mtime, sizeof(mtime), "@%ld", options->timestamp);
-+ snprintf(mtime, sizeof(mtime), "@%" PRId64, options->timestamp);
-
- command_init(&cmd, TAR, "tar -cf");
- command_add_args(&cmd, "tar", "-cf", "-", "--format=gnu",
-diff -upr dpkg-1.20.5.orig/lib/dpkg/perf.h dpkg-1.20.5/lib/dpkg/perf.h
---- dpkg-1.20.5.orig/lib/dpkg/perf.h 2019-11-27 14:39:09.000000000 +0100
-+++ dpkg-1.20.5/lib/dpkg/perf.h 2020-08-27 23:00:58.851649314 +0200
-@@ -24,6 +24,7 @@
-
- #include <config.h>
- #include <compat.h>
-+#include <inttypes.h>
-
- #include <time.h>
- #include <stdio.h>
-@@ -50,7 +51,7 @@ perf_ts_mark_print(const char *str)
-
- clock_gettime(CLOCK_MONOTONIC, &ts);
-
-- printf("%lu.%.9lu: %s\n", ts.tv_sec, ts.tv_nsec, str);
-+ printf("%" PRId64 ".%.9lu: %s\n", ts.tv_sec, ts.tv_nsec, str);
- }
-
- static void
-@@ -60,7 +61,7 @@ perf_ts_slot_print(struct perf_slot *ps,
-
- perf_ts_sub(&ps->t_end, &ps->t_ini, &t_res);
-
-- printf("%lu.%.9lu: %s (%lu.%.9lu sec)\n",
-+ printf("%" PRId64 ".%.9lu: %s (%lu.%.9lu sec)\n",
- ps->t_end.tv_sec, ps->t_end.tv_nsec,
- str, t_res.tv_sec, t_res.tv_nsec);
- }
-diff -upr dpkg-1.20.5.orig/lib/dpkg/pkg-format.c dpkg-1.20.5/lib/dpkg/pkg-format.c
---- dpkg-1.20.5.orig/lib/dpkg/pkg-format.c 2020-06-02 04:51:37.000000000 +0200
-+++ dpkg-1.20.5/lib/dpkg/pkg-format.c 2020-08-27 23:01:24.044984684 +0200
-@@ -31,6 +31,7 @@
- #include <stdlib.h>
- #include <stdio.h>
- #include <unistd.h>
-+#include <inttypes.h>
-
- #include <dpkg/i18n.h>
- #include <dpkg/error.h>
-@@ -299,7 +300,7 @@ virt_fsys_last_modified(struct varbuf *v
- pkgbin_name_const(pkg, pkgbin, pnaw_nonambig));
- }
-
-- varbuf_printf(vb, "%ld", st.st_mtime);
-+ varbuf_printf(vb, "%" PRId64, st.st_mtime);
- }
-
- /*
-diff -upr dpkg-1.20.5.orig/lib/dpkg/t/c-tarextract.c dpkg-1.20.5/lib/dpkg/t/c-tarextract.c
---- dpkg-1.20.5.orig/lib/dpkg/t/c-tarextract.c 2020-06-02 04:51:37.000000000 +0200
-+++ dpkg-1.20.5/lib/dpkg/t/c-tarextract.c 2020-08-27 23:01:53.108320365 +0200
-@@ -31,6 +31,7 @@
- #include <stdio.h>
- #include <stdlib.h>
- #include <unistd.h>
-+#include <inttypes.h>
-
- #include <dpkg/ehandle.h>
- #include <dpkg/fdio.h>
-@@ -65,7 +66,7 @@ tar_object_skip(struct tar_archive *tar,
- static int
- tar_object(struct tar_archive *tar, struct tar_entry *te)
- {
-- printf("%s mode=%o time=%ld.%.9d uid=%d gid=%d", te->name,
-+ printf("%s mode=%o time=%" PRId64 ".%.9d uid=%d gid=%d", te->name,
- te->stat.mode, te->mtime, 0, te->stat.uid, te->stat.gid);
- if (te->stat.uname)
- printf(" uname=%s", te->stat.uname);