aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-03-28 18:12:50 +0100
committerRasmus Thomsen <oss@cogitri.dev>2020-05-09 17:24:23 +0000
commit2b9b893294c7de2a0573f8956e153e778dbc1215 (patch)
treef812d252cffcf4b7540d87d26fa86fbb08c0dad4
parent59c863da1caa90fc459ff6536f41bb54539eb7a3 (diff)
testing/py3-gtts: new aport
-rw-r--r--testing/py3-gtts/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/py3-gtts/APKBUILD b/testing/py3-gtts/APKBUILD
new file mode 100644
index 00000000000..da9da93f5e2
--- /dev/null
+++ b/testing/py3-gtts/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=py3-gtts
+pkgver=2.1.1
+pkgrel=0
+pkgdesc="A Python library and CLI tool to interface with Google Translate text-to-speech API"
+url="https://github.com/pndurette/gTTS"
+arch="noarch"
+license="MIT"
+depends="python3 py3-twine py3-gtts-token py3-click py3-beautifulsoup4"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest py3-mock py3-testfixtures"
+source="https://pypi.python.org/packages/source/g/gTTS/gTTS-$pkgver.tar.gz"
+# Net required for tests
+# Tests fail currently https://github.com/pndurette/gTTS/issues/220
+options="!check"
+builddir="$srcdir/gTTS-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ pytest
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="bbffe64ce8821a6fcc2f8146a07d1e06cda95b791544f1dcdf7cf687e9c39818fc299baca52e5c14306a1954ec7a9906638aea238334e7be9af45c96e9aebd7e gTTS-2.1.1.tar.gz"