aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-10-20 04:38:07 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-10-20 16:44:17 +0000
commit300e2122495d606fc02cfa8852339f56dcfd80d7 (patch)
treeeec81441a680b4fc8972d2f3802abe1716db059b
parentbf76e300b15bfac7a4ea9d24ae0a93c4a5834274 (diff)
community/py3-aiohttp: relax yarl dependecy
fixes #12029
-rw-r--r--community/py3-aiohttp/APKBUILD9
-rw-r--r--community/py3-aiohttp/relax-yarl.patch16
2 files changed, 22 insertions, 3 deletions
diff --git a/community/py3-aiohttp/APKBUILD b/community/py3-aiohttp/APKBUILD
index 152d3faff9d..0e536decc86 100644
--- a/community/py3-aiohttp/APKBUILD
+++ b/community/py3-aiohttp/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-aiohttp
_pkgname=aiohttp
pkgver=3.6.3
-pkgrel=0
+pkgrel=1
pkgdesc="HTTP client/server for asyncio"
url="https://pypi.python.org/pypi/aiohttp"
arch="all"
@@ -12,7 +12,9 @@ depends="python3 py3-async-timeout py3-chardet py3-multidict py3-yarl
py3-idna-ssl py3-attrs"
makedepends="python3-dev py3-setuptools"
subpackages="$pkgname-dev"
-source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
+ relax-yarl.patch
+ "
builddir="$srcdir/$_pkgname-$pkgver"
build() {
@@ -27,4 +29,5 @@ package() {
python3 setup.py install --root="$pkgdir" --optimize=1
}
-sha512sums="21a0272c2805bda8809e151e48e0ae2661a00239b7898cc627e273b8b17ffe27f29373d0a7d2f1c628469a905e18835906a8068e336e8901a6ab0c2043353d97 py3-aiohttp-3.6.3.tar.gz"
+sha512sums="21a0272c2805bda8809e151e48e0ae2661a00239b7898cc627e273b8b17ffe27f29373d0a7d2f1c628469a905e18835906a8068e336e8901a6ab0c2043353d97 py3-aiohttp-3.6.3.tar.gz
+4038dcc2be15243596dee67250573a571d63912d1b2f4c22d5748565469beaac322c6df18907e0c1a84873602af0e373022e69f43260da7878f8f4f9643b17f7 relax-yarl.patch"
diff --git a/community/py3-aiohttp/relax-yarl.patch b/community/py3-aiohttp/relax-yarl.patch
new file mode 100644
index 00000000000..11349f0bc39
--- /dev/null
+++ b/community/py3-aiohttp/relax-yarl.patch
@@ -0,0 +1,16 @@
+Upstream: taken from https://github.com/aio-libs/aiohttp/commit/ce50b036e75852b57a99389f2735f8c2153efb14
+Reason: We use py3-yarl>1.6.0 (1.6.2 at the time of writing this), so relax deps
+
+diff --git a/setup.py b/setup.py
+index 9913039..8039b51 100644
+--- a/setup.py
++++ b/setup.py
+@@ -76,7 +76,7 @@ install_requires = [
+ 'chardet>=2.0,<4.0',
+ 'multidict>=4.5,<5.0',
+ 'async_timeout>=3.0,<4.0',
+- 'yarl>=1.0,<1.6.0',
++ 'yarl>=1.0,<2.0',
+ 'idna-ssl>=1.0; python_version<"3.7"',
+ 'typing_extensions>=3.6.5; python_version<"3.7"',
+ ]