aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-21 22:03:57 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-21 22:07:44 +0000
commit346b1f4abdb797c3b797b075ce7df8ae8abf17ea (patch)
tree5cca540a5b0cbfc5c19682dfb9ff3b1f60878517
parentb8e11aff4c567c24f2087860929d7fc15d0e7e0e (diff)
community/unibilium: add check
-rw-r--r--community/unibilium/APKBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/community/unibilium/APKBUILD b/community/unibilium/APKBUILD
index eb47427cff3..69304e01736 100644
--- a/community/unibilium/APKBUILD
+++ b/community/unibilium/APKBUILD
@@ -2,14 +2,14 @@
# Maintainer: Marvin Steadfast <marvin@xsteadfastx.org>
pkgname=unibilium
pkgver=1.2.1
-pkgrel=0
+pkgrel=1
pkgdesc="A terminfo parsing library"
url="https://github.com/mauke/unibilium/"
arch="all"
license="LGPL3"
-depends=""
depends_dev="libtool"
makedepends="$depends_dev"
+checkdepends="perl-dev"
subpackages="$pkgname-dev $pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/mauke/$pkgname/archive/v$pkgver.tar.gz
build-static-lib.patch"
@@ -20,6 +20,11 @@ build() {
make PREFIX=/usr
}
+check() {
+ cd "$builddir"
+ make test
+}
+
package() {
cd "$builddir"
make PREFIX=/usr DESTDIR="$pkgdir" install