aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntoine Fontaine <antoine.fontaine@epfl.ch>2020-05-31 23:21:33 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-06-26 17:25:46 +0000
commit36dcebf338121cd0742936f0fa271c2e8ee14094 (patch)
treeb73a59ce91b1c947df2dc5125795e56bb7a005fa
parent81ce71e2c72a14eabf62e39f8cb8f66671babf1c (diff)
testing/py3-hpack: new aports
-rw-r--r--testing/py3-hpack/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/py3-hpack/APKBUILD b/testing/py3-hpack/APKBUILD
new file mode 100644
index 00000000000..8ab3fe5d6c3
--- /dev/null
+++ b/testing/py3-hpack/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Antoine Fontaine <antoine.fontaine@epfl.ch>
+# Maintainer: Antoine Fontaine <antoine.fontaine@epfl.ch>
+pkgname=py3-hpack
+pkgver=3.0.0
+pkgrel=0
+pkgdesc="HTTP/2 framing layer for Python"
+url="https://hyper.rtfd.org/"
+arch="noarch"
+license="MIT"
+depends="python3"
+checkdepends="py3-pytest py3-hypothesis"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/h/hpack/hpack-$pkgver.tar.gz"
+builddir="$srcdir/hpack-$pkgver"
+options="!check" # testsuite appears to miss some py3-pytest-* dependency
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ cd test
+ python3 -m pytest
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="ffac4bdf19f8826027d8f89fe07e1837eacabbf18d1ff18e0cb13505c6714afd62125aa5cc594c75273725be71cc6e17b2315257fabb7779ce51de8c877267a3 hpack-3.0.0.tar.gz"