aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-28 16:36:06 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-28 16:36:19 +0000
commit38e0ed32a8b187bb71d7a6fa4146ac66911c07a8 (patch)
tree83b18782797bc96ce631fc39fc6d536ee12b18d8
parentf14c400d1661e819aba8e99e80bf7605b6b19a2a (diff)
community/iptstate: add simple check and modernize
Add a simple test as upstream doesn't provide a test suite.
-rw-r--r--community/iptstate/APKBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/community/iptstate/APKBUILD b/community/iptstate/APKBUILD
index 2fc76a5f7a4..fec940093e5 100644
--- a/community/iptstate/APKBUILD
+++ b/community/iptstate/APKBUILD
@@ -2,8 +2,8 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=iptstate
pkgver=2.2.6
-pkgrel=0
-pkgdesc="top-like interface to netfilter connection-tracking table"
+pkgrel=1
+pkgdesc="Top-like interface to netfilter connection-tracking table"
url="https://www.phildev.net/iptstate/"
arch="all"
license="MIT"
@@ -11,10 +11,16 @@ makedepends="ncurses-dev libnetfilter_conntrack-dev libnfnetlink-dev linux-heade
subpackages="$pkgname-doc"
source="https://github.com/jaymzh/iptstate/releases/download/v$pkgver/$pkgname-$pkgver.tar.bz2"
-builddir="$srcdir"/$pkgname-$pkgver
+builddir="$srcdir/$pkgname-$pkgver"
+
build() {
cd "$builddir"
- make || return 1
+ make
+}
+
+check() {
+ cd "$builddir"
+ ./iptstate --help > /dev/null
}
package() {
@@ -24,6 +30,4 @@ package() {
install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
-md5sums="ec96c93b43976960d2e2ba3306cd09e6 iptstate-2.2.6.tar.bz2"
-sha256sums="bef8eb67a4533e53079f397b71e91dd34da23f8cbd65cb2d5b67cb907b00c068 iptstate-2.2.6.tar.bz2"
sha512sums="411b357aced384c52caac17b23f3c6bd631ff34d41b6000b90ff6dfc3cf20e36e46416d3691ac699b06f16d6042a42681b42a5d3594ce287aa6cf3b3b637c999 iptstate-2.2.6.tar.bz2"