aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-12-06 02:37:19 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-12-06 02:37:40 -0300
commit3a436a10cc1af5e6ba0f81c19bd09497eeb08197 (patch)
tree8d58598bd717cdb5e1381410015c852c05296e6f
parent3c00f20a0051ff125cf0b070b03bfdaf561aaf8f (diff)
community/cpio: fix build with -fno-common
-rw-r--r--community/cpio/APKBUILD17
-rw-r--r--community/cpio/gcc-10.patch26
2 files changed, 34 insertions, 9 deletions
diff --git a/community/cpio/APKBUILD b/community/cpio/APKBUILD
index 83a3822a7be..cabc947c1e0 100644
--- a/community/cpio/APKBUILD
+++ b/community/cpio/APKBUILD
@@ -2,14 +2,16 @@
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=cpio
pkgver=2.13
-pkgrel=0
-pkgdesc="A tool to copy files into or out of a cpio or tar archive"
+pkgrel=1
+pkgdesc="tool to copy files into or out of a cpio or tar archive"
url="https://www.gnu.org/software/cpio"
arch="all"
-license="GPL"
+license="GPL-3.0-or-later"
checkdepends="autoconf"
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.bz2::http://ftp.snt.utwente.nl/pub/software/gnu/cpio/$pkgname-$pkgver.tar.bz2"
+source="$pkgname-$pkgver.tar.bz2::http://ftp.snt.utwente.nl/pub/software/gnu/cpio/cpio-$pkgver.tar.bz2
+ gcc-10.patch
+ "
# secfixes:
# 2.13-r0:
@@ -18,10 +20,8 @@ source="$pkgname-$pkgver.tar.bz2::http://ftp.snt.utwente.nl/pub/software/gnu/cpi
# 2.12-r3:
# - CVE-2016-2037
-builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -38,16 +38,15 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
rm -f "$pkgdir"/usr/lib/charset.alias
rm -f "$pkgdir"/usr/libexec/rmt # part of the tar pkg
rm "$pkgdir"/usr/share/man/*/rmt.*
}
-sha512sums="459398e69f7f48201c04d1080218c50f75edcf114ffcbb236644ff6fcade5fcc566929bdab2ebe9be5314828d6902e43b348a8adf28351df978c8989590e93a3 cpio-2.13.tar.bz2"
+sha512sums="459398e69f7f48201c04d1080218c50f75edcf114ffcbb236644ff6fcade5fcc566929bdab2ebe9be5314828d6902e43b348a8adf28351df978c8989590e93a3 cpio-2.13.tar.bz2
+c04e657c05ba93a03191666de93527be6b646eaa155043db7fd517e98f7a8ed61c281efb067c66f3c14f350b869866ca21c9634ce678a17c3a108c2a4ab87276 gcc-10.patch"
diff --git a/community/cpio/gcc-10.patch b/community/cpio/gcc-10.patch
new file mode 100644
index 00000000000..0b1ceafbdef
--- /dev/null
+++ b/community/cpio/gcc-10.patch
@@ -0,0 +1,26 @@
+From 641d3f489cf6238bb916368d4ba0d9325a235afb Mon Sep 17 00:00:00 2001
+From: Sergey Poznyakoff <gray@gnu.org>
+Date: Mon, 20 Jan 2020 07:45:39 +0200
+Subject: Minor fix * src/global.c: Remove superfluous declaration of
+ program_name
+
+---
+ src/global.c | 3 ---
+ 1 file changed, 3 deletions(-)
+
+diff --git a/src/global.c b/src/global.c
+index fb3abe9..acf92bc 100644
+--- a/src/global.c
++++ b/src/global.c
+@@ -184,9 +184,6 @@ unsigned int warn_option = 0;
+ /* Extract to standard output? */
+ bool to_stdout_option = false;
+
+-/* The name this program was run with. */
+-char *program_name;
+-
+ /* A pointer to either lstat or stat, depending on whether
+ dereferencing of symlinks is done for input files. */
+ int (*xstat) ();
+--
+cgit v1.2.1