aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Polański <michal@polanski.me>2021-03-21 23:16:59 +0100
committerLeo <thinkabit.ukim@gmail.com>2021-03-22 02:59:47 +0000
commit3bd40b31d601d172a2a6eb763b37f91972158ec3 (patch)
treeceba45b5e2e1a3726aa69d28ebf6d9b48df1541b
parent073bfe297fb55ec033a6e30f98778edd86652f6f (diff)
testing/fnott: new aport
Keyboard driven and lightweight Wayland notification daemon https://codeberg.org/dnkl/fnott
-rw-r--r--testing/fnott/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/fnott/APKBUILD b/testing/fnott/APKBUILD
new file mode 100644
index 00000000000..adae9b07b7b
--- /dev/null
+++ b/testing/fnott/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Michał Polański <michal@polanski.me>
+# Maintainer: Michał Polański <michal@polanski.me>
+pkgname=fnott
+pkgver=1.0.1
+pkgrel=0
+pkgdesc="Keyboard driven and lightweight Wayland notification daemon"
+url="https://codeberg.org/dnkl/fnott"
+license="MIT"
+arch="all"
+options="!check" # no test suite
+makedepends="
+ meson
+ pixman-dev
+ libpng-dev
+ wayland-protocols
+ wayland-dev
+ dbus-dev
+ tllist-dev
+ fcft-dev
+ scdoc
+ "
+subpackages="$pkgname-doc $pkgname-zsh-completion"
+source="$pkgname-$pkgver.tar.gz::https://codeberg.org/dnkl/fnott/archive/$pkgver.tar.gz"
+builddir="$srcdir/fnott"
+
+build() {
+ abuild-meson . output
+ meson compile -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
+}
+
+sha512sums="5f8c3ba29af792875b0ac2e585cfebd453c92be064711b9d82a5cf6249fccda2cdeacc2a96b0b8b4a485590f10255d3e257339d85c99cccc3158ebc516959f22 fnott-1.0.1.tar.gz"