aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2021-01-09 12:44:59 +0100
committerLeo <thinkabit.ukim@gmail.com>2021-01-09 18:35:16 +0000
commit3c15213d30c7e2c787a507e302f01432e4eb382b (patch)
tree11d310f4ebe707a5d4bd6574e73f1856ba4f8b7c
parent4773f3540a9bfc0e43b2391aee0a02742f7d5bf4 (diff)
community/py3-scripttest: move from testing
-rw-r--r--community/py3-pip/APKBUILD5
-rw-r--r--community/py3-scripttest/APKBUILD (renamed from testing/py3-scripttest/APKBUILD)0
2 files changed, 4 insertions, 1 deletions
diff --git a/community/py3-pip/APKBUILD b/community/py3-pip/APKBUILD
index 719ec6df25b..330d895465d 100644
--- a/community/py3-pip/APKBUILD
+++ b/community/py3-pip/APKBUILD
@@ -31,9 +31,11 @@ depends="
"
makedepends="
py3-sphinx
+ py3-sphinx-inline-tabs
"
checkdepends="
py3-pytest
+ py3-mock
"
subpackages="
$pkgname-doc
@@ -41,6 +43,7 @@ subpackages="
$pkgname-bash-completion:bashcomp:noarch
"
source="https://github.com/pypa/pip/archive/$pkgver/pip-$pkgver.tar.gz"
+options="net" # Needed to build docs
builddir="$srcdir/pip-$pkgver"
provides="py-pip=$pkgver-r$pkgrel" # Backwards compatibility
@@ -66,7 +69,7 @@ build() {
# Build manpage
cd docs/
- PYTHONPATH="$builddir/src/" python3 pip_sphinxext.py
+# PYTHONPATH="$builddir/src/" python3 pip_sphinxext.py
PYTHONPATH="$builddir/src/" sphinx-build -W -b man -d build/doctrees/man man build/man -c html
}
diff --git a/testing/py3-scripttest/APKBUILD b/community/py3-scripttest/APKBUILD
index 99bc16f5f8a..99bc16f5f8a 100644
--- a/testing/py3-scripttest/APKBUILD
+++ b/community/py3-scripttest/APKBUILD