aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Polański <michal@polanski.me>2022-06-15 01:10:19 +0200
committerJakub Jirutka <jakub@jirutka.cz>2022-06-25 21:18:19 +0000
commit3d0bdd3bdfb1da7f7d02ed8f01000e522ab55ed6 (patch)
treef6550c0949c2d54bc9073367d44f4b86aa04ad83
parent60c99aeb0915efb5296d563b4a208784300765ea (diff)
testing/tuc: new aport
When cut doesn't cut it https://github.com/riquito/tuc
-rw-r--r--testing/tuc/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/tuc/APKBUILD b/testing/tuc/APKBUILD
new file mode 100644
index 00000000000..1367b68befa
--- /dev/null
+++ b/testing/tuc/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Michał Polański <michal@polanski.me>
+# Maintainer: Michał Polański <michal@polanski.me>
+pkgname=tuc
+pkgver=0.10.0
+pkgrel=0
+pkgdesc="When cut doesn't cut it"
+url="https://github.com/riquito/tuc"
+license="GPL-3.0-or-later"
+arch="all !s390x !riscv64" # blocked by rust/cargo
+makedepends="cargo"
+source="https://github.com/riquito/tuc/archive/v$pkgver/tuc-$pkgver.tar.gz"
+
+prepare() {
+ default_prepare
+
+ cargo fetch --locked
+}
+
+build() {
+ cargo build --frozen --release
+}
+
+check() {
+ cargo test --frozen
+}
+
+package() {
+ install -Dm755 target/release/tuc -t "$pkgdir"/usr/bin/
+}
+
+sha512sums="
+3595d985db8f74cd2749b264411d8df4d045ab1ffc52e44853f1a867b035b979c1206aaaefe7f570f0824637e8c3fdabd07a64e0439b90db0ba98b21b036de7c tuc-0.10.0.tar.gz
+"