aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Segre <jan@segre.in>2020-09-28 03:14:22 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-10-01 23:21:41 +0000
commit3d5054f358faad1a4e76497547b023defd79cc6c (patch)
tree087b8dc6850812fce4fe12ff2937445c20bdb07c
parentfda180492bc864759262f0f1648af172326a32db (diff)
testing/rocksdb: upgrade to 5.18.4
-rw-r--r--testing/rocksdb/10-support-busybox-install.patch5
-rw-r--r--testing/rocksdb/APKBUILD27
2 files changed, 16 insertions, 16 deletions
diff --git a/testing/rocksdb/10-support-busybox-install.patch b/testing/rocksdb/10-support-busybox-install.patch
index 1e20378c33b..0cc5463ff47 100644
--- a/testing/rocksdb/10-support-busybox-install.patch
+++ b/testing/rocksdb/10-support-busybox-install.patch
@@ -1,3 +1,8 @@
+Upstream uses `install -C` but in alpine the install command is from busybox
+which does not support the `-C` flag, `-c` is perfectly fine for packaging.
+
+---
+
--- a/Makefile
+++ b/Makefile
@@ -1548,14 +1548,14 @@
diff --git a/testing/rocksdb/APKBUILD b/testing/rocksdb/APKBUILD
index e58ee969a7f..eca4e32e275 100644
--- a/testing/rocksdb/APKBUILD
+++ b/testing/rocksdb/APKBUILD
@@ -1,40 +1,35 @@
# Contributor: James Bowes <jbowes@repl.ca>
+# Contributor: Jan Segre <jan@segre.in>
# Maintainer:
pkgname=rocksdb
-pkgver=5.15.10
-pkgrel=4
+pkgver=5.18.4
+pkgrel=0
pkgdesc="A persistent key-value store for fast storage environments"
url="https://rocksdb.org"
-# fails to build on other archs
-arch="x86 x86_64 ppc64le"
-arch="" # Fails to build with gcc-9+
-license="GPL-2.0"
-depends=""
-depends_dev="bzip2-dev snappy-dev zlib-dev lz4-dev zstd-dev"
+arch="x86 x86_64 ppc64le aarch64" # fails to build on other archs
+license="Apache-2.0 OR GPL-2.0-only"
+depends_dev="bzip2-dev gflags-dev lz4-dev snappy-dev zlib-dev zstd-dev"
makedepends="$depends_dev linux-headers bash perl"
-install=""
subpackages="$pkgname-dev $pkgname-doc"
options="!check" # no upstream/available test-suite
-source="$pkgname-$pkgver.tar.gz::https://github.com/facebook/$pkgname/archive/v$pkgver.tar.gz
+source="$pkgname-$pkgver.tar.gz::https://github.com/facebook/rocksdb/archive/v$pkgver.tar.gz
ppc64le-determine-platform.patch
10-support-busybox-install.patch"
-_builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$_builddir"
- make shared_lib
+ make shared_lib DISABLE_WARNING_AS_ERROR=1
}
package() {
- cd "$_builddir"
INSTALL_PATH="$pkgdir"/usr make install-shared
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+ install -Dm644 LICENSE.Apache "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.Apache
mkdir -p "$pkgdir"/usr/share/doc
cp -a docs "$pkgdir"/usr/share/doc/$pkgname
install -Dm644 README.md "$pkgdir"/usr/share/doc/$pkgname/README.md
install -Dm644 HISTORY.md "$pkgdir"/usr/share/doc/$pkgname/HISTORY.md
}
-sha512sums="3faef43cc343c20e044f92af7cd9eae9783612d888bfe17b7d0ae6812090088f43a128e5686600ec56f5a88c100eaa893b2551f8c32df793a4ccd94330c07037 rocksdb-5.15.10.tar.gz
+sha512sums="52532acd786299b7ab901f4046119f98b3b13ff44f01358c944d04b9257a829e424e86f7f1909e765285d380b59d0aee9dc2da59f170eccfb05c7cdae897680f rocksdb-5.18.4.tar.gz
a7445cf958e414b6eac8a4f05e82fa980c00276da7305a158f3fa77f71bdff606713cd88fae8db0b9fb97125fef646e9e6245fef3a3f2e97d0ef20be259fb37d ppc64le-determine-platform.patch
-2b33041baa061e6cedfcbc606fd9752d907ebba84cb76ff13641ac4683e614e527530453bcbe0e0c6b67b36415dee477aec268024a05b8815c534f4d6bfb6cc0 10-support-busybox-install.patch"
+9c7abee8944fadebe05e873188229d0c687b06a5b75b939f4139264ba7a4cf7690f36234e7c4b6fba5738c98d291d1078cd1deb58b0538aba1c1d2d996f72696 10-support-busybox-install.patch"