aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-06-07 13:11:49 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-06-14 17:37:48 -0300
commit3e35cda614fd71a83697dd8f54eb0ba113e36815 (patch)
tree4ed412a1fca354e4e4b52b55843db29f5c3e6d15
parent46ef93178955f18f217fffc17a6ffa2833a350f0 (diff)
community/perl-io-tee: fix URL&License
* modernize
-rw-r--r--community/perl-io-tee/APKBUILD15
1 files changed, 5 insertions, 10 deletions
diff --git a/community/perl-io-tee/APKBUILD b/community/perl-io-tee/APKBUILD
index 9c0ba2f1c65..ee1f00efa04 100644
--- a/community/perl-io-tee/APKBUILD
+++ b/community/perl-io-tee/APKBUILD
@@ -3,32 +3,27 @@
pkgname=perl-io-tee
pkgver=0.65
_realname=IO-Tee-$pkgver
-pkgrel=0
+pkgrel=1
pkgdesc="Multiplex output to multiple output handles"
-url="http://search.cpan.org/dist/IO-Tee/"
+url="https://metacpan.org/pod/IO::Tee"
arch="noarch"
-license="GPL PerlArtistic"
-cpandepends=""
-cpanmakedepends=""
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl"
+makedepends="perl-dev"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://cpan.metacpan.org/authors/id/N/NE/NEILB/$_realname.tar.gz"
builddir="$srcdir"/$_realname
build() {
- cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}