aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2018-12-31 12:51:49 +0100
committerAndy Postnikov <apostnikov@gmail.com>2019-01-05 21:51:02 +0200
commit3e700e36c62d09b405ccd21c8f1dff4273b53474 (patch)
tree9de1d488363e5b843ad2d5c5c1486e1379274779
parente97c353394e98dc7c2acfdd454c7bcc1192e1aab (diff)
community/captagent: rebuild against openssl
-rw-r--r--community/captagent/APKBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/community/captagent/APKBUILD b/community/captagent/APKBUILD
index 17b301814f3..39ab5c03cf8 100644
--- a/community/captagent/APKBUILD
+++ b/community/captagent/APKBUILD
@@ -2,13 +2,13 @@
# Maintainer: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
pkgname=captagent
pkgver=6.3.0
-pkgrel=5
+pkgrel=6
pkgdesc="HEP Capture Agent for HOMER"
url="https://github.com/sipcapture/captagent"
arch="all"
license="GPL-3.0-or-later"
makedepends="autoconf automake bison expat-dev flex flex-dev json-c-dev
- libgcrypt-dev libpcap-dev libtool libuv-dev linux-headers libressl-dev"
+ libgcrypt-dev libpcap-dev libtool libuv-dev linux-headers openssl-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/sipcapture/captagent/archive/$pkgver.tar.gz
$pkgname.initd
ac-fix.patch
@@ -27,6 +27,11 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ ./src/captagent -v
+}
+
package() {
cd "$builddir"